Fix core Perl module Module::Pluggable such that it can find plugins that live in symlinked directories. Patch borrowed/adapted from Nixpkgs. --- perl-5.16.1/cpan/Module-Pluggable/lib/Module/Pluggable/Object.pm 2015-04-08 23:28:48.120164135 -0500 +++ perl-5.16.1/cpan/Module-Pluggable/lib/Module/Pluggable/Object.pm 2015-04-08 23:30:27.032166704 -0500 @@ -164,7 +164,7 @@ my $sp = catdir($dir, (split /::/, $searchpath)); # if it doesn't exist or it's not a dir then skip it - next unless ( -e $sp && -d _ ); # Use the cached stat the second time + next unless ( -e $sp ); my @files = $self->find_files($sp); @@ -279,7 +279,7 @@ (my $path = $File::Find::name) =~ s#^\\./##; push @files, $path; } - }, $search_path ); + }, "$search_path/." ); } #chdir $cwd; return @files; td>
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lirc.scm
AgeCommit message (Expand)Author
2019-03-31gnu: Fix descriptions to not use quotes.Efraim Flashner
2019-01-25gnu: python-lirc: Update to 1.2.1-2.c28708b.Ricardo Wurmus
2019-01-15gnu: Separate Python core packages from the rest.Ricardo Wurmus
2018-11-29gnu: lirc: Build reproducibly.Ludovic Courtès
2017-09-28gnu: lirc: Update to 0.10.1.Alex Kost
2017-06-26gnu: lirc: Fix building on Ubuntu.Tobias Geerinckx-Rice
2016-11-15gnu: Remove python-setuptools and python2-setuptools from inputs (part 2)Hartmut Goebel
2016-08-19gnu: python-lirc: Fix file-name.Leo Famulari
2016-08-16gnu: Add python-lirc.Danny Milosavljevic
2016-07-21gnu: Update URLs for sourceforge.net.Leo Famulari
2016-06-04gnu: lirc: Update to 0.9.4.Alex Kost
2016-04-14gnu: packages: Use 'search-patches' everywhere.Alex Kost
2015-10-04gnu: lirc: Update to 0.9.3.Alex Kost
2015-03-26gnu: Add LIRC.Alex Kost