Fix Perl module Module::Pluggable such that it can find plugins that live in symlinked directories. Patch borrowed/adapted from Nixpkgs. --- Module-Pluggable-5.2/lib/Module/Pluggable/Object.pm 2015-04-08 23:28:48.120164135 -0500 +++ Module-Pluggable-5.2/lib/Module/Pluggable/Object.pm 2015-04-08 23:30:27.032166704 -0500 @@ -164,7 +164,7 @@ my $sp = catdir($dir, (split /::/, $searchpath)); # if it doesn't exist or it's not a dir then skip it - next unless ( -e $sp && -d _ ); # Use the cached stat the second time + next unless ( -e $sp ); my @files = $self->find_files($sp); @@ -279,7 +279,7 @@ (my $path = $File::Find::name) =~ s#^\\./##; push @files, $path; } - }, $search_path ); + }, "$search_path/." ); } #chdir $cwd; return @files;Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/dunst.scm
AgeCommit message (Expand)Author
2022-03-16gnu: dunst: Update to 1.8.1....* gnu/packages/dunst.scm (dunst): Update to 1.8.1. * gnu/packages/patches/dunst-1.7.3-fix-crash.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Jai Vetrivelan
2022-02-04gnu: dunst: Fix crash on invalid pixbuf notification....* gnu/packages/patches/dunst-1.7.3-fix-crash.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/dunst.scm (dunst)[source]<#:patches>: Add it. Danny Milosavljevic
2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès
2021-12-13Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-12-12gnu: dunst : Update to 1.7.3....* gnu/packages/dunst.scm (dunst): Update to 1.7.3. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> gyara
2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-11-11gnu: gtk: Replace gdk-pixbuf+svg by librsvg....With the addition of a profile hook for computing the gdk-pixbuf loaders cache file, there is no longer a need for gdk-pixbuf+svg, and librsvg can propagate gdk-pixbuf without fear, so replace the former for the latter. The replacement was automated with the following command: $ git grep -l ',gdk-pixbuf+svg)' \ | xargs sed 's/(".*" ,gdk-pixbuf+svg)/("librsvg" ,librsvg)/' -i * gnu/packages/gtk.scm (gdk-pixbuf+svg): Delete package. (gtk+-2)[propagated-inputs]: Replace gdk-pixbuf+svg with librsvg. (gtk+)[propagated-inputs]: Likewise. * gnu/packages/gnome.scm (gdk-pixbuf+svg): Add deprecated package. Maxim Cournoyer
2021-11-09gnu: dunst: Update to 1.7.1....* gnu/packages/dunst.scm (dunst): Update to 1.7.1. Guillaume Le Vaillant
2021-11-01gnu: dunst: Update to 1.7.0....* gnu/packages/dunst.scm (dunst): Update to 1.7.0. [source]: Fix indentation. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Alexandr Vityazev