Fix Perl module Module::Pluggable such that it can find plugins that live in symlinked directories. Patch borrowed/adapted from Nixpkgs. --- Module-Pluggable-5.2/lib/Module/Pluggable/Object.pm 2015-04-08 23:28:48.120164135 -0500 +++ Module-Pluggable-5.2/lib/Module/Pluggable/Object.pm 2015-04-08 23:30:27.032166704 -0500 @@ -164,7 +164,7 @@ my $sp = catdir($dir, (split /::/, $searchpath)); # if it doesn't exist or it's not a dir then skip it - next unless ( -e $sp && -d _ ); # Use the cached stat the second time + next unless ( -e $sp ); my @files = $self->find_files($sp); @@ -279,7 +279,7 @@ (my $path = $File::Find::name) =~ s#^\\./##; push @files, $path; } - }, $search_path ); + }, "$search_path/." ); } #chdir $cwd; return @files;ix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/toys.scm
td>
AgeCommit message (Expand)Author
2018-01-18gnu: Add sl....Tobias Geerinckx-Rice
2018-01-19gnu: Consistently Write ‘file system(s)’....Tobias Geerinckx-Rice
2017-10-11gnu: gparted: Update to 0.30.0....Tobias Geerinckx-Rice
2017-09-22gnu: Use xxd instead of vim....Ricardo Wurmus
2017-09-15gnu: Add pydf....Stefan Reichör
2017-09-01gnu: gparted: Update home page....Tobias Geerinckx-Rice
2017-07-29gnu: gptfdisk: Update to 1.0.3....Tobias Geerinckx-Rice
2017-07-28gnu: gptfdisk: Update description....Tobias Geerinckx-Rice
2017-07-25gnu: fdisk: Update to 2.0.0a1....Tobias Geerinckx-Rice
2017-07-25gnu: sdparm: Update to 1.10....Tobias Geerinckx-Rice
2017-05-09gnu: Add f3....Hartmut Goebel
2017-02-24gnu: gparted: Update to 0.28.1....Tobias Geerinckx-Rice
2017-02-15gnu: gptfdisk: Install the documentation....Leo Famulari
2017-02-15gnu: gparted: Update to 0.28.0....Tobias Geerinckx-Rice
2017-02-06gnu: dosfstools: Update to 4.1....Marius Bakke
2017-02-06gnu: ddrescue: Update to 1.22....Marius Bakke