Fix Perl module Module::Pluggable such that it can find plugins that live in symlinked directories. Patch borrowed/adapted from Nixpkgs. --- Module-Pluggable-5.2/lib/Module/Pluggable/Object.pm 2015-04-08 23:28:48.120164135 -0500 +++ Module-Pluggable-5.2/lib/Module/Pluggable/Object.pm 2015-04-08 23:30:27.032166704 -0500 @@ -164,7 +164,7 @@ my $sp = catdir($dir, (split /::/, $searchpath)); # if it doesn't exist or it's not a dir then skip it - next unless ( -e $sp && -d _ ); # Use the cached stat the second time + next unless ( -e $sp ); my @files = $self->find_files($sp); @@ -279,7 +279,7 @@ (my $path = $File::Find::name) =~ s#^\\./##; push @files, $path; } - }, $search_path ); + }, "$search_path/." ); } #chdir $cwd; return @files;zed Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/logging.scm
AgeCommit message (Expand)Author
2018-06-26gnu: glog: Return #t from all phases....Tobias Geerinckx-Rice
2018-03-09gnu: 'autoconf-wrapper' is no longer a procedure....Ludovic Courtès
2018-01-05gnu: log4cpp: Update to 1.1.3....Tobias Geerinckx-Rice
2018-01-04gnu: glog: Disable signal-handler unit tests....Eric Bavier
2017-11-13gnu: Move web packages from python to python-web....Ludovic Courtès
2017-09-04gnu: Put autoconf-related phases immediately after the 'unpack phase....Kei Kebreau
2017-08-09gnu: Update tailon to version 1.3.0....Christopher Baines
2017-05-26gnu: Add multitail....Stefan Reichoer
2017-05-24gnu: glog: Update to 0.3.5....Marius Bakke
2017-05-17gnu: tailon: Use absolute paths for commands....Christopher Baines
2017-05-01gnu: Add tailon....Christopher Baines
2017-04-04gnu: glog: Fix name demangling for GCC 5....Ludovic Courtès
2016-06-29gnu: Add glog....Ludovic Courtès
2016-06-15gnu: Add log4cpp....Ricardo Wurmus