Fix Perl module Module::Pluggable such that it can find plugins that live in
symlinked directories.
Patch borrowed/adapted from Nixpkgs.
--- Module-Pluggable-5.2/lib/Module/Pluggable/Object.pm 2015-04-08 23:28:48.120164135 -0500
+++ Module-Pluggable-5.2/lib/Module/Pluggable/Object.pm 2015-04-08 23:30:27.032166704 -0500
@@ -164,7 +164,7 @@
my $sp = catdir($dir, (split /::/, $searchpath));
# if it doesn't exist or it's not a dir then skip it
- next unless ( -e $sp && -d _ ); # Use the cached stat the second time
+ next unless ( -e $sp );
my @files = $self->find_files($sp);
@@ -279,7 +279,7 @@
(my $path = $File::Find::name) =~ s#^\\./##;
push @files, $path;
}
- }, $search_path );
+ }, "$search_path/." );
}
#chdir $cwd;
return @files;>
Age | Commit message (Expand) | Author |
2023-11-07 | build: Fix spelling in m4 macros....* m4/guix.m4 (GUIX_CHECK_GUILE_SSH): Fix spelling of parameter.
(GUIX_CHECK_FILE_NAME_LIMITS): Fix spelling of maximum.
Change-Id: I93c80441393622a4bc06daa475eee13874cca527
| Efraim Flashner |
2023-03-16 | build: Correct guix_system on musl libc distros....* m4/guix.m4 (GUIX_SYSTEM_TYPE): Add linux-musl* case. This prevents
the macro from mis-parsing the host OS, which causes breakage when
building from source.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Antero Mejr |