Fix Perl module Module::Pluggable such that it can find plugins that live in symlinked directories. Patch borrowed/adapted from Nixpkgs. --- Module-Pluggable-5.2/lib/Module/Pluggable/Object.pm 2015-04-08 23:28:48.120164135 -0500 +++ Module-Pluggable-5.2/lib/Module/Pluggable/Object.pm 2015-04-08 23:30:27.032166704 -0500 @@ -164,7 +164,7 @@ my $sp = catdir($dir, (split /::/, $searchpath)); # if it doesn't exist or it's not a dir then skip it - next unless ( -e $sp && -d _ ); # Use the cached stat the second time + next unless ( -e $sp ); my @files = $self->find_files($sp); @@ -279,7 +279,7 @@ (my $path = $File::Find::name) =~ s#^\\./##; push @files, $path; } - }, $search_path ); + }, "$search_path/." ); } #chdir $cwd; return @files;
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
AgeCommit message (Expand)Author
2021-06-26gnu: php: Build sodium....* gnu/packages/php.scm (php): Build sodium extension. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Aljosha Papsch
2021-06-03gnu: php: Update to 7.4.20....* gnu/packages/php.scm (php): Update to 7.4.20. Tobias Geerinckx-Rice
2021-05-06gnu: php: Update to 7.4.19....* gnu/packages/php.scm (php): Update to 7.4.19. Tobias Geerinckx-Rice
2021-05-01gnu: php: Update to 7.4.18....* gnu/packages/php.scm (php): Update to 7.4.18. [arguments]: Delete yet another failing test (proc_nice_basic). Tobias Geerinckx-Rice
2021-03-05gnu: php: Update to 7.4.16 [security fixes]....* gnu/packages/php.scm (php): Update to 7.4.16. [arguments]: Patch failing new test. Tobias Geerinckx-Rice
2021-02-26gnu: php: Disable failing test on Arm....* gnu/packages/php.scm (php): Disable timing sensitive failing test on Arm. Julien Lepiller
2021-02-09gnu: php: Disable failing tests on arm....* gnu/packages/php.scm (arguments)[phases]: Disable additional failing tests on arm. Julien Lepiller
2021-02-08gnu: php: Update to 7.4.15....* gnu/packages/php.scm (php): Update to 7.4.15. Julien Lepiller
2021-01-07gnu: php: Update to 7.4.14....* gnu/packages/php.scm (php): Update to 7.4.14. Julien Lepiller