Work around a problem arising from the update to OpenSSL 1.0.2f, based on the
following upstream commit:
https://github.com/noxxi/p5-io-socket-ssl/commit/6e23ee4a433f83f1065bd2467255eba5ee9b1ddd
Attempting to update to IO-Socket-SSL-2.023, which includes this commit,
caused other test failures. See:
https://lists.gnu.org/archive/html/guix-devel/2016-01/msg01032.html
Description from the upstream commit:
OpenSSL 1.0.2f changed the behavior of SSL shutdown in case the TLS connection
was not fully established (commit: f73c737c7ac908c5d6407c419769123392a3b0a9).
This somehow resulted in Net::SSLeay::shutdown returning 0 (i.e. keep trying)
which caused an endless loop. It will now ignore this result in case the TLS
connection was not yet established and consider the TLS connection closed
instead.
--- IO-Socket-SSL-2.002/lib/IO/Socket/SSL.pm.orig 2014-10-21 16:51:16.000000000 -0400
+++ IO-Socket-SSL-2.002/lib/IO/Socket/SSL.pm 2016-01-31 15:07:14.971099894 -0500
@@ -1213,6 +1213,11 @@
# shutdown complete
last;
}
+ if ((${*$self}{'_SSL_opened'}||0) <= 0) {
+ # not really open, thus don't expect shutdown to return
+ # something meaningful
+ last;
+ }
# initiate or complete shutdown
local $SIG{PIPE} = 'IGNORE';
ecommitdiff
|
Age | Commit message (Expand) | Author |
2021-04-24 | services: Add a service for rasdaemon....* gnu/services/linux.scm (rasdaemon-configuration, rasdaemon-configuration?,
rasdaemon-configuration-record?, rasdaemon-service-type): New variables.
* doc/guix.texi (Linux Services): Document it.
Signed-off-by: Leo Famulari <leo@famulari.name>
| B. Wilson |
2021-02-08 | gnu: Remove 'file-systems requirement from kernel-module-loader....* gnu/services/linux.scm (kernel-module-loader-shepherd-service):
Remove 'file-systems requirement.
Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
| raid5atemyhomework |
2021-01-06 | services: kernel-module-loader: Return a single 'shepherd-service'....* gnu/services/linux.scm (kernel-module-loader-shepherd-service): Return
a 'shepherd-service' instead of a list of it.
(kernel-module-loader-service-type): Adjust it.
Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
| Brice Waegeneire |
2020-09-13 | services: Fix zram-device-service....* gnu/services/linux.scm (<zram-device-configuration>): Fix typo.
| Tobias Geerinckx-Rice |
2020-08-02 | services: Add zram-device-service....* gnu/services/linux.scm (<zram-device-configuration>): New record.
(zram-device-service-type): New variable.
* doc/guix.texi (Linux Services): Document it.
* tests/services/linux.scm (zram-swap-device-test): New tests.
| Efraim Flashner |