AutoSplit will fail to create an index for files whose modification time is 0 because its default time for a non-existent index is 1. Set this default time to -1 instead. --- perl-5.16.1/cpan/AutoLoader/lib/AutoSplit.pm.orig 2012-02-14 22:44:36.000000000 -0600 +++ perl-5.16.1/cpan/AutoLoader/lib/AutoSplit.pm 2015-09-09 19:59:22.208708921 -0500 @@ -361,7 +361,7 @@ my($al_idx_file) = catfile($autodir, $modpname, $IndexFile); if ($check_mod_time){ - my($al_ts_time) = (stat("$al_idx_file"))[9] || 1; + my($al_ts_time) = (stat("$al_idx_file"))[9] || -1; if ($al_ts_time >= $pm_mod_time and $al_ts_time >= $self_mod_time){ print "AutoSplit skipped ($al_idx_file newer than $filename)\n" Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-01-16 23:14:41 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-21 21:24:26 +0100
commit79e074ea10875ff75ca613179c70de12d64b19f5 (patch)
tree3814bb2199bc80d22c3198cb4beb84a3daf04ec9
parenta7d470e47dab0acd00da43860e19e12edd50bcbb (diff)
downloadguix-79e074ea10875ff75ca613179c70de12d64b19f5.tar.gz
guix-79e074ea10875ff75ca613179c70de12d64b19f5.zip
gnu: nim: Fix /bin/sh substitution in C code.
* gnu/packages/nim.scm (nim)[arguments]: Patch the string length too. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat