Patch for from . --- trunk/pcre_internal.h 2016/05/21 13:34:44 1649 +++ trunk/pcre_internal.h 2017/02/24 17:30:30 1688 @@ -2772,6 +2772,9 @@ extern const pcre_uint16 PRIV(ucd_stage2)[]; extern const pcre_uint32 PRIV(ucp_gentype)[]; extern const pcre_uint32 PRIV(ucp_gbtable)[]; +#ifdef COMPILE_PCRE32 +extern const ucd_record PRIV(dummy_ucd_record)[]; +#endif #ifdef SUPPORT_JIT extern const int PRIV(ucp_typerange)[]; #endif @@ -2780,9 +2783,15 @@ /* UCD access macros */ #define UCD_BLOCK_SIZE 128 -#define GET_UCD(ch) (PRIV(ucd_records) + \ +#define REAL_GET_UCD(ch) (PRIV(ucd_records) + \ PRIV(ucd_stage2)[PRIV(ucd_stage1)[(int)(ch) / UCD_BLOCK_SIZE] * \ UCD_BLOCK_SIZE + (int)(ch) % UCD_BLOCK_SIZE]) + +#ifdef COMPILE_PCRE32 +#define GET_UCD(ch) ((ch > 0x10ffff)? PRIV(dummy_ucd_record) : REAL_GET_UCD(ch)) +#else +#define GET_UCD(ch) REAL_GET_UCD(ch) +#endif #define UCD_CHARTYPE(ch) GET_UCD(ch)->chartype #define UCD_SCRIPT(ch) GET_UCD(ch)->script --- trunk/pcre_ucd.c 2014/06/19 07:51:39 1490 +++ trunk/pcre_ucd.c 2017/02/24 17:30:30 1688 @@ -38,6 +38,20 @@ const pcre_uint32 PRIV(ucd_caseless_sets)[] = {0}; #else +/* If the 32-bit library is run in non-32-bit mode, character values +greater than 0x10ffff may be encountered. For these we set up a +special record. */ + +#ifdef COMPILE_PCRE32 +const ucd_record PRIV(dummy_ucd_record)[] = {{ + ucp_Common, /* script */ + ucp_Cn, /* type unassigned */ + ucp_gbOther, /* grapheme break property */ + 0, /* case set */ + 0, /* other case */ + }}; +#endif + /* When recompiling tables with a new Unicode version, please check the types in this structure definition from pcre_internal.h (the actual field names will be different): ze='10' name='q' value=''/>
AgeCommit message (Expand)Author
2018-05-04guix build: Nicely report unbound variables with hints....Ludovic Courtès
2018-03-13gnu: time: Update to 1.9....Efraim Flashner
2017-11-11tests: Refer to "time@1.8"....Ludovic Courtès
2017-05-01packages: Remove support for PACKAGE-VERSION deprecated syntax....Ludovic Courtès
2017-04-21store: 'GUIX_DAEMON_SOCKET' can now be a URI....Ludovic Courtès
2017-03-19gnu: Rename "guile-next" to "guile"....Ludovic Courtès
2016-10-03tests: Adjust 'guix build -S' test for source-less packages....Ludovic Courtès
2016-09-06packages: Add 'package-superseded' and associated support....Ludovic Courtès
2016-03-08packages: Support the deprecated "NAME-VERSION" syntax....Ludovic Courtès
2016-03-03guix build: -S returns the replacement's source....Ludovic Courtès
2016-03-02utils: Use '@' for separating package names and version numbers....Mathieu Lirzin
2016-03-02tests: Disable grafts by default....Ludovic Courtès
2016-02-01guix build: Add '--with-input'....Ludovic Courtès