Upstream-status: Not presented upstream.
--- pciutils-3.8.0/lib/hurd.c.orig 2024-11-07 15:09:20.728973822 +0100
+++ pciutils-3.8.0/lib/hurd.c 2024-11-07 15:05:08.524682813 +0100
@@ -213,7 +213,7 @@
hurd_read(struct pci_dev *d, int pos, byte * buf, int len)
{
int err;
- size_t nread;
+ mach_msg_type_number_t nread;
char *data;
mach_port_t device_port = device_port_lookup(d);
@@ -266,7 +266,7 @@
mach_port_t device_port = device_port_lookup(d);
struct pci_bar regions[6];
char *buf = (char *) ®ions;
- size_t size = sizeof(regions);
+ mach_msg_type_number_t size = sizeof(regions);
int err = pci_get_dev_regions(device_port, &buf, &size);
if (err)
@@ -305,7 +305,7 @@
struct pci_xrom_bar rom;
mach_port_t device_port = device_port_lookup(d);
char *buf = (char *) &rom;
- size_t size = sizeof(rom);
+ mach_msg_type_number_t size = sizeof(rom);
int err = pci_get_dev_rom(device_port, &buf, &size);
if (err)
td>
|
Age | Commit message (Expand) | Author |
2021-01-16 | services: openntpd: Remove support for deprecated "-s" option....* gnu/services/networking.scm (openntpd-configuration): Remove
"allow-large-adjustment?" field.
(openntpd-shepherd-service): Remove use of "allow-large-adjustment?"
configuration field and "-s" daemon option.
* tests/networking.scm (%openntpd-conf-sample): Remove
"allow-large-adjustment?" field.
* doc/guix.texi (Networking Services)[openntpd-service-type]: Remove
"allow-large-adjustment?" field from sample configuration.
[openntpd-configuration]: Remove description of "allow-large-adjustment?"
field.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Simon South |
2019-10-30 | services: ntp: Ensure no double quotes are output to config file....* gnu/services/networking.scm (ntp-server->string): Use the textual
representation of the values as printed by 'display' rather than 'write', to
avoid inserting double quotes in the generated config.
* tests/networking.scm (%ntp-server-sample): Add a comment and make one of the
options a string, to exercise the fix.
("ntp-server->string"): Move the expected value to the first argument.
("ntp configuration servers deprecated form"): Likewise.
("openntpd generated config string ends with a newline"): Likewise.
| Maxim Cournoyer |
2019-09-08 | services: openntpd: Add test for issue #3731....See http://debbugs.gnu.org/cgi/bugreport.cgi?bug=37318.
* gnu/services/networking.scm (openntpd-configuration->string): New procedure,
extracted from top of the `openntpd-shepherd-service' to make it testable.
(openntpd-shepherd-service): Adapt following the move of the code to the above
procedure.
* tests/networking.scm: Add a test for the `openntpd-configuration->string'
procedure.
| Maxim Cournoyer |
2019-09-08 | services: ntp: Support different NTP server types and options....* gnu/services/networking.scm (ntp-server-types): New enum.
(<ntp-server>): New record type.
(ntp-server->string): New procedure.
(%ntp-servers): Define in terms of <htp-server> records. Use the first
entrypoint server as a pool instead of a list of static servers. This is more
resilient since a new server of the pool can be interrogated on every
request. Add the 'iburst' options.
(ntp-configuration-servers): Define a custom accessor that warns but honors
the now deprecated server format.
(<ntp-configuration>): Use it.
(%openntpd-servers): New variable,
(<openntpd-configuration>): Use it, as a pool ('servers' field) instead of a
regular server.
* tests/networking.scm: New file.
* Makefile.am (SCM_TESTS): Register it.
* doc/guix.texi: Update documentation.
| Maxim Cournoyer |