Add ability to detect GNU/Hurd when configuring. Adapted from https://git.hadrons.org/cgit/debian/pkgs/pciutils.git/tree/debian/patches/00-configure-hurd.patch From e39a3af22501234a91cf28e8c57b45f9379f9101 Mon Sep 17 00:00:00 2001 From: Damien Zammit Date: Fri, 26 Oct 2018 09:24:04 -0400 Subject: [PATCH 2/2] Add ability to detect GNU/Hurd when configuring --- lib/configure | 6 +++++- 1 file changed, 5 insertions(+), 1 deletion(-) --- a/lib/configure +++ b/lib/configure @@ -25,7 +25,7 @@ if [ -z "$HOST" ] ; then proc=`/usr/sbin/lsdev -C -c processor -S available -F name | head -1` cpu=`/usr/sbin/lsattr -F value -l $proc -a type | sed 's/_.*//'` else - cpu=`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/;s/^BePC$/i386/;s/^BeMac$/powerpc/;s/^BeBox$/powerpc/'` + cpu=`uname -m | sed 's/^i.86-AT386/i386/;s/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/;s/^BePC$/i386/;s/^BeMac$/powerpc/;s/^BeBox$/powerpc/'` fi if [ "$sys" = "DragonFly" ] then @@ -39,6 +39,10 @@ if [ -z "$HOST" ] ; then then sys=cygwin fi + if [ "$sys" = "GNU" ] + then + sys=gnu + fi HOST=${3:-$cpu-$sys} fi [ -n "$RELEASE" ] && rel="${RELEASE}" 41de2'>refslogtreecommitdiff
path: root/gnu/packages/groff.scm
AgeCommit message (Collapse)Author
2018-05-06gnu: groff-minimal: Preserve 'preconv' executable.Marius Bakke
* gnu/packages/groff.scm (groff-minimal)[arguments]: Add 'preconv' to the list of kept programs.
2017-12-06gnu: groff-minimal: Inherit phases from groff.Marius Bakke
* gnu/packages/groff.scm (groff-minimal)[arguments]: Use 'substitute-keyword-arguments' to prevent phases from "groff" overriding the phases in groff-minimal.
2017-12-05Merge branch 'master' into core-updatesMarius Bakke
2017-12-02gnu: Add groff-minimal.Ludovic Courtès
* gnu/packages/groff.scm (groff-minimal): New variable.
2017-08-31gnu: groff: Make build reproducible.Danny Milosavljevic
* gnu/packages/groff.scm (groff)[arguments]: Add phase "setenv".
2017-07-10gnu: groff: Remove timestamps.Danny Milosavljevic
Fixes <https://bugs.gnu.org/27593>. * gnu/packages/patches/groff-source-date-epoch.patch: New file. * gnu/local.mk: Add it. * gnu/packages/groff.scm (groff)[source]: Add it.
2017-07-07gnu: groff: Remove dependency on netpbm.Ludovic Courtès
* gnu/packages/groff.scm (groff)[inputs]: Remove 'netpbm'.
2017-03-30gnu: Use HTTPS for almost all gnu.org HOME-PAGEs.Tobias Geerinckx-Rice
All HTTP gnu.org (and supported subdomain) HOME-PAGEs changed to HTTPS.
2016-12-25gnu: Add roffit.Ricardo Wurmus
* gnu/packages/groff.scm (roffit): New variable.