The gendiff1 and gendiff2 tests need the gendiff script that's distributed
with the rpm package management tool. Without that script, these tests are
expected to fail.
Need to mark one of the tests as PHONY to get permissions set correctly on
built scripts.
--- a/Makefile.in 2011-02-10 09:44:43.000000000 -0600
+++ b/Makefile.in 2014-03-06 17:27:55.610048953 -0600
@@ -378,6 +378,8 @@
# These ones don't work yet.
# Feel free to send me patches. :-)
XFAIL_TESTS = \
+ tests/gendiff1/run-test \
+ tests/gendiff2/run-test \
tests/delhunk5/run-test \
tests/delhunk6/run-test
@@ -1106,6 +1108,7 @@
rm -f $(DESTDIR)$(bindir)/"`echo lsdiff|sed '$(transform)'`"
rm -f $(DESTDIR)$(bindir)/"`echo grepdiff|sed '$(transform)'`"
+.PHONY: tests/combine1/run-test
tests/combine1/run-test: src/combinediff$(EXEEXT) src/flipdiff$(EXEEXT) \
src/lsdiff$(EXEEXT) src/grepdiff$(EXEEXT)
for script in $(bin_SCRIPTS); do \
|
Age | Commit message (Expand) | Author |
2019-08-28 | accounts: Delete duplicate entries....When adding multiple instances of a service requiring some user
account/group, we could end up with multiple entries for that account or
group in /etc/passwd or /etc/group.
* gnu/build/accounts.scm (database-writer)[write-entries]: Add call to
'delete-duplicates'.
* tests/accounts.scm ("write-passwd with duplicate entry"): New test.
| Ludovic Courtès |
2019-04-27 | tests: Adjust accounts test to shell-as-config change....This is a followup to 504a0fc636ec591e65b4a229a37e522e425d8a0c.
* tests/accounts.scm ("allocate-passwd with previous state"): Change
expected 'shell' for "alice" to "/bin/sh".
| Ludovic Courtès |
2019-03-25 | accounts: Add default value for the 'home-directory' field of <user-account>....* gnu/system/accounts.scm (<user-account>)[home-directory]: Mark as
thunked and add a default value.
(default-home-directory): New procedure.
* doc/guix.texi (User Accounts): Remove 'home-directory' from example.
* gnu/system/examples/bare-bones.tmpl: Likewise.
* gnu/system/examples/beaglebone-black.tmpl: Likewise.
* gnu/system/examples/desktop.tmpl: Likewise.
* gnu/system/examples/docker-image.tmpl: Likewise.
* gnu/system/examples/lightweight-desktop.tmpl: Likewise.
* gnu/system/install.scm (installation-os): Likewise.
* gnu/tests.scm (%simple-os): Likewise.
* gnu/tests/install.scm (%minimal-os, %minimal-os-on-vda):
(%separate-home-os, %encrypted-root-os, %btrfs-root-os): Likewise.
* tests/accounts.scm ("allocate-passwd")
("allocate-passwd with previous state"): Likewise.
| Ludovic Courtès |
2019-03-07 | Add (gnu build accounts)....* gnu/build/accounts.scm, tests/accounts.scm: New files.
* Makefile.am (SCM_TESTS): Add tests/accounts.scm.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add build/accounts.scm.
| Ludovic Courtès |