Need to mark one of the tests as PHONY to get permissions set correctly on
built scripts.
--- a/Makefile.in 2011-02-10 09:44:43.000000000 -0600
+++ b/Makefile.in 2018-11-29 21:52:05.000000000 -0600
@@ -1106,5 +1108,6 @@
rm -f $(DESTDIR)$(bindir)/"`echo lsdiff|sed '$(transform)'`"
rm -f $(DESTDIR)$(bindir)/"`echo grepdiff|sed '$(transform)'`"
+.PHONY: tests/newline1/run-test
tests/newline1/run-test: src/combinediff$(EXEEXT) src/flipdiff$(EXEEXT) \
src/lsdiff$(EXEEXT) src/grepdiff$(EXEEXT) \
scripts/splitdiff
/'>guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2022-01-19 | etc: Match define-public only at line start....The current regexp simply matches the first occurence, which more often than
not points to the *previous* variable.
* etc/snippets/text-mode/guix-commit-message-update-package ($1): Restrict
match to beginning of line with optional indentation.
| Liliana Marie Prikler |
2021-06-26 | etc: snippets: Use ‘hg-file-name’ when origin uses ‘hg-fetch’...Adjust to changes in commit aaafd19bd1e37265de07e246286a6819792c25b4.
* etc/snippets/scheme-mode/guix-origin: Use ‘hg-file-name’ instead of
‘string-append’ when ‘method’ for origin is ‘hg-fetch’.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Xinglu Chen |
2020-12-23 | etc: snippets: Add new build systems to package snippet....* etc/snippets/scheme-mode/guix-package: Add the following as possibilities
for the build-system field:
clojure-build-system
copy-build-system
dune-build-system
guile-build-system
julia-build-system
linux-module-build-system
maven-build-system
node-build-system
qt-build-system
rakudo-build-system
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Morgan Smith |