Skip Thai character test when libthai is unavailable. Taken from upstream bug tracker: https://gitlab.gnome.org/GNOME/pango/merge_requests/161 https://gitlab.gnome.org/GNOME/pango/commit/b73284747ac937e31dc9191f84ed6e24284c88ee diff --git a/tests/test-break.c b/tests/test-break.c index 8549b678bba69360d07dce3af21d915412f20d51..47fa3009165e19a331aa04a0df4351ae2323933b 100644 --- a/tests/test-break.c +++ b/tests/test-break.c @@ -305,6 +305,12 @@ main (int argc, char *argv[]) if (!strstr (name, "break")) continue; +#ifndef HAVE_LIBTHAI + /* four.break involves Thai, so only test it when we have libthai */ + if (strstr (name, "four.break")) + continue; +#endif + path = g_strdup_printf ("/break/%s", name); g_test_add_data_func_full (path, g_test_build_filename (G_TEST_DIST, "breaks", name, NULL), test_break, g_free); Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/build/marionette.scm
AgeCommit message (Expand)Author
2019-05-15marionette: Add braces to the keystrokes....Ludovic Courtès
2018-08-28marionette: Add wait-for-unix-socket....Chris Marusich
2018-08-28marionette: Add support for QEMU's "quit" command....Chris Marusich
2018-06-01marionette: Add 'wait-for-tcp-port'....Ludovic Courtès
2018-02-19marionette: Use QEMU's "VM channel" mechanism....Ludovic Courtès
2017-09-08marionette: 'wait-for-file' can be passed a read procedure....Ludovic Courtès
2017-08-28marionette: Augment the set of keystrokes....Ludovic Courtès
2017-08-28marionette: Fix typing of capital letters....Ludovic Courtès
2017-08-28marionette: 'wait-for-file' really raises an error when a file is missing....Ludovic Courtès
2017-06-12marionette: Factorize 'wait-for-file'....Ludovic Courtès
2016-11-23install: Enable "cryptodisk" handling in GRUB....Ludovic Courtès
2016-11-23marionette: Add 'marionette-screen-text' using OCR....Ludovic Courtès
2016-11-23marionette: Delay synchronization with the host's REPL....Ludovic Courtès
2016-11-22marionette: Avoid use of SIGALRM for timeouts....Ludovic Courtès
2016-05-04Add (gnu tests) and (gnu build marionette)....Ludovic Courtès