Skip Thai character test when libthai is unavailable.
Taken from upstream bug tracker:
https://gitlab.gnome.org/GNOME/pango/merge_requests/161
https://gitlab.gnome.org/GNOME/pango/commit/b73284747ac937e31dc9191f84ed6e24284c88ee
diff --git a/tests/test-break.c b/tests/test-break.c
index 8549b678bba69360d07dce3af21d915412f20d51..47fa3009165e19a331aa04a0df4351ae2323933b 100644
--- a/tests/test-break.c
+++ b/tests/test-break.c
@@ -305,6 +305,12 @@ main (int argc, char *argv[])
if (!strstr (name, "break"))
continue;
+#ifndef HAVE_LIBTHAI
+ /* four.break involves Thai, so only test it when we have libthai */
+ if (strstr (name, "four.break"))
+ continue;
+#endif
+
path = g_strdup_printf ("/break/%s", name);
g_test_add_data_func_full (path, g_test_build_filename (G_TEST_DIST, "breaks", name, NULL),
test_break, g_free);
r>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2018-12-09 | gnu: polkit: Fix CVE-2018-19788....* gnu/packages/patches/polkit-CVE-2018-19788.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/polkit.scm (polkit)[source]: Use it.
| Leo Famulari |
2018-08-09 | gnu: polkit: Update to 0.115 [fixes CVE-2018-1116]....* gnu/packages/polkit.scm (polkit): Update to 0.115.
[origin]: Adjust snippet.
[inputs]: Replace mozjs with mozjs-52.
* gnu/packages/patches/polkit-drop-test.patch: Remove patch.
* gnu/local.mk (dist_patch_DATA): Remove it.
(cherry picked from commit 50afd712312a4b9fa42d7f9d03464e542b3aeb75)
Signed-off-by: Marius Bakke <mbakke@fastmail.com>
| Ricardo Wurmus |
2018-02-27 | gnu: polkit: Fix 'invoke' call....* gnu/packages/polkit.scm (polkit)[arguments] <'install>: Add 'apply'.
Fixes a regression introduced in 3c4bbb4c52418c8daf8b0e4605e3912685c9f44a.
| Ludovic Courtès |
2018-02-26 | gnu: Use HTTPS for supported freedesktop.org home pages....* gnu/packages/fontutils.scm (fontconfig)[home-page]: Use HTTPS.
* gnu/packages/freedesktop.scm (python-pyxdg, accountsservice)
(modem-manager, telepathy-mission-control, telepathy-mission-control)
(colord-gtk, desktop-file-utils)[home-page]: Likewise.
* gnu/packages/ghostscript.scm (libspectre)[home-page]: Likewise.
* gnu/packages/glib.scm (dbus, dbus-glib, telepathy-glib)[home-page]:
Likewise.
* gnu/packages/gnome.scm (shared-mime-info, hicolor-icon-theme)
(libxklavier, colord, upower)[home-page]: Likewise.
* gnu/packages/gstreamer.scm (orc, python-gst)[home-page]: Likewise.
* gnu/packages/libcanberra.scm (sound-theme-freedesktop)[home-page]:
Likewise.
* gnu/packages/libreoffice.scm (libexttextcat)[home-page]: Likewise.
* gnu/packages/polkit.scm (polkit-gnome, polkit-gnome)[home-page]:
Likewise.
* gnu/packages/pulseaudio.scm (pavucontrol)[home-page]: Likewise.
* gnu/packages/python.scm (python-dbus)[home-page]: Likewise.
* gnu/packages/xdisorg.scm (startup-notification)[home-page]: Likewise.
| Tobias Geerinckx-Rice |
2018-02-26 | gnu: polkit: Update phase & snippet style....* gnu/packages/polkit.scm (polkit)[source]: End snippet with #t.
[arguments]: Substitute INVOKE for SYSTEM* and end phases with #t.
| Tobias Geerinckx-Rice |