Fix CVE-2020-10595:
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-10595
Patch copied from upstream advisory:
https://seclists.org/oss-sec/2020/q1/128
diff --git a/prompting.c b/prompting.c
index e985d95..d81054f 100644
--- a/prompting.c
+++ b/prompting.c
@@ -314,26 +314,27 @@ pamk5_prompter_krb5(krb5_context context UNUSED, void *data, const char *name,
/*
* Reuse pam_prompts as a starting index and copy the data into the reply
* area of the krb5_prompt structs.
*/
pam_prompts = 0;
if (name != NULL && !args->silent)
pam_prompts++;
if (banner != NULL && !args->silent)
pam_prompts++;
for (i = 0; i < num_prompts; i++, pam_prompts++) {
- size_t len;
+ size_t len, allowed;
if (resp[pam_prompts].resp == NULL)
goto cleanup;
len = strlen(resp[pam_prompts].resp);
- if (len > prompts[i].reply->length)
+ allowed = prompts[i].reply->length;
+ if (allowed == 0 || len > allowed - 1)
goto cleanup;
/*
* The trailing nul is not included in length, but other applications
* expect it to be there. Therefore, we copy one more byte than the
* actual length of the password, but set length to just the length of
* the password.
*/
memcpy(prompts[i].reply->data, resp[pam_prompts].resp, len + 1);
prompts[i].reply->length = (unsigned int) len;
4f8d5e63b2f83fc0b9297e874f03c8424303b488'>diff
|
Age | Commit message (Expand) | Author |
2020-12-21 | Merge branch 'master' into ungrafting | Marius Bakke |
2020-12-14 | gnu: Add python-3.9....* gnu/packages/python.scm (python-3.9): New variable.
* gnu/packages/patches/python-3.9-fix-tests.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Tanguy Le Carrour |
2020-12-08 | gnu: Python: Fix CVE-2020-26116....* gnu/packages/patches/python-CVE-2020-26116.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/python.scm (python-3.8)[source](patches): Add it.
| Marius Bakke |
2020-10-26 | gnu: python: Disable failing tests for the Hurd....Fixes <https://bugs.gnu.org/43860>.
* gnu/packages/python.scm (python-3.8)[arguments]: When building for the Hurd,
disable more tests.
| Jan (janneke) Nieuwenhuizen |
2020-09-29 | gnu: micropython: Update to 1.13....* gnu/packages/python.scm (micropython): Update to 1.13.
| Nicolas Goaziou |
2020-09-14 | gnu: python-wrapper: Mention pip in description....* gnu/packages/python.scm (python-wrapper)[description]: Mention that `pip'
won't work properly if both python and python-wrapper are installed.
| Pierre Neidhardt |