Fix CVE-2020-10595: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-10595 Patch copied from upstream advisory: https://seclists.org/oss-sec/2020/q1/128 diff --git a/prompting.c b/prompting.c index e985d95..d81054f 100644 --- a/prompting.c +++ b/prompting.c @@ -314,26 +314,27 @@ pamk5_prompter_krb5(krb5_context context UNUSED, void *data, const char *name, /* * Reuse pam_prompts as a starting index and copy the data into the reply * area of the krb5_prompt structs. */ pam_prompts = 0; if (name != NULL && !args->silent) pam_prompts++; if (banner != NULL && !args->silent) pam_prompts++; for (i = 0; i < num_prompts; i++, pam_prompts++) { - size_t len; + size_t len, allowed; if (resp[pam_prompts].resp == NULL) goto cleanup; len = strlen(resp[pam_prompts].resp); - if (len > prompts[i].reply->length) + allowed = prompts[i].reply->length; + if (allowed == 0 || len > allowed - 1) goto cleanup; /* * The trailing nul is not included in length, but other applications * expect it to be there. Therefore, we copy one more byte than the * actual length of the password, but set length to just the length of * the password. */ memcpy(prompts[i].reply->data, resp[pam_prompts].resp, len + 1); prompts[i].reply->length = (unsigned int) len; 34e1b34eb49a29c96bc7a1d1fac4'>diff
path: root/tests/signing-key.sec
ng `mdate-from-git.scm'....
AgeCommit message (Expand)Author
Janneke Nieuwenhuizen
2024-04-19maint: Support `make doc-pot-update' from a tarball....Janneke Nieuwenhuizen
2024-04-14maint: Fix header....Janneke Nieuwenhuizen
2024-04-14maint: Use xgettext.scm wrapper to create .PO files reproducibly....Janneke Nieuwenhuizen
2024-01-05build: test-driver.scm: Set mode....Tomas Volf
2023-08-21maint: Add 'etc/hurd-manifest.scm'....Janneke Nieuwenhuizen
2023-07-25cuirass: Update hurd-manifest with newly supported packages....Janneke Nieuwenhuizen