Building p7zip with GCC 11 or newer normally fails with error messages like ../../../../CPP/7zip/Archive/Wim/WimHandler.cpp:308:11: error: use of an operand of type ‘bool’ in ‘operator++’ is forbidden in C++17 308 | numMethods++; | ^~~~~~~~~~ This patch causes GCC to interpret the code using the GNU dialect of the C++14 standard, as GCC 10 did by default, and reduces these errors to warnings. diff --git a/makefile.linux_amd64_asm b/makefile.linux_amd64_asm index 075c6a8..b7d73ee 100644 --- a/makefile.linux_amd64_asm +++ b/makefile.linux_amd64_asm @@ -11,6 +11,8 @@ ALLFLAGS=-m64 ${OPTFLAGS} -pipe \ -D_7ZIP_ASM \ $(LOCAL_FLAGS) +ALLFLAGS_CPP=-std=gnu++14 + CXX=g++ CC=gcc CC_SHARED=-fPIC diff --git a/makefile.linux_any_cpu_gcc_4.X b/makefile.linux_any_cpu_gcc_4.X index be093b5..c0f3120 100644 --- a/makefile.linux_any_cpu_gcc_4.X +++ b/makefile.linux_any_cpu_gcc_4.X @@ -10,7 +10,7 @@ ALLFLAGS=${OPTFLAGS} -pipe \ -D_7ZIP_LARGE_PAGES \ $(LOCAL_FLAGS) -ALLFLAGS_CPP=-DENV_HAVE_GCCVISIBILITYPATCH -fvisibility=hidden -fvisibility-inlines-hidden +ALLFLAGS_CPP=-DENV_HAVE_GCCVISIBILITYPATCH -std=gnu++14 -fvisibility=hidden -fvisibility-inlines-hidden CXX=g++ CC=gcc diff --git a/makefile.linux_x86_asm_gcc_4.X b/makefile.linux_x86_asm_gcc_4.X index 1ac339b..6e736d9 100644 --- a/makefile.linux_x86_asm_gcc_4.X +++ b/makefile.linux_x86_asm_gcc_4.X @@ -12,7 +12,7 @@ ALLFLAGS=${OPTFLAGS} -pipe -m32 \ -D_7ZIP_ASM \ $(LOCAL_FLAGS) -ALLFLAGS_CPP=-DENV_HAVE_GCCVISIBILITYPATCH -fvisibility=hidden -fvisibility-inlines-hidden +ALLFLAGS_CPP=-DENV_HAVE_GCCVISIBILITYPATCH -std=gnu++14 -fvisibility=hidden -fvisibility-inlines-hidden CXX=g++ CC=gcc select name='qt'>
path: root/gnu/system/file-systems.scm
AgeCommit message (Expand)Author
2020-05-20bootloader: grub: Allow booting from a Btrfs subvolume....Maxim Cournoyer
2020-05-20file-systems: Add helpers for parsing the options string into an alist....Maxim Cournoyer
2020-04-27file-systems: mount the PID cgroup filesystem....Jakub Kądziołka
2020-03-02file-systems: Add a 'file-system-device->string' procedure....Maxim Cournoyer
2019-11-04file-systems: Mount /var/run/nscd read-write in containers....Ludovic Courtès
2019-09-12file-systems: Add /var/run/nscd to '%network-file-mappings'....Ludovic Courtès
2019-07-19file-systems: Use 'no-atime' for %IMMUTABLE-STORE....Ludovic Courtès
2018-06-14install: Use (guix store database) instead of 'guix-register'....Ludovic Courtès
2018-05-28file-systems: Remove 'title' field and add <file-system-label>....Ludovic Courtès
2018-05-19file-systems: Do not export <file-system>....Ludovic Courtès