Fix CVE-2017-17969: https://sourceforge.net/p/p7zip/bugs/204/ https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-17969 Patch copied from Debian. Subject: Heap-based buffer overflow in 7zip/Compress/ShrinkDecoder.cpp Origin: vendor, https://sourceforge.net/p/p7zip/bugs/_discuss/thread/0920f369/27d7/attachment/CVE-2017-17969.patch Forwarded: https://sourceforge.net/p/p7zip/bugs/_discuss/thread/0920f369/#27d7 Bug: https://sourceforge.net/p/p7zip/bugs/204/ Bug-Debian: https://bugs.debian.org/888297 Bug-Debian-Security: https://security-tracker.debian.org/tracker/CVE-2017-17969 Author: Antoine Beaupré Reviewed-by: Salvatore Bonaccorso Last-Update: 2018-02-01 Applied-Upstream: 18.00-beta --- a/CPP/7zip/Compress/ShrinkDecoder.cpp +++ b/CPP/7zip/Compress/ShrinkDecoder.cpp @@ -121,8 +121,13 @@ HRESULT CDecoder::CodeReal(ISequentialIn { _stack[i++] = _suffixes[cur]; cur = _parents[cur]; + if (cur >= kNumItems || i >= kNumItems) + break; } - + + if (cur >= kNumItems || i >= kNumItems) + break; + _stack[i++] = (Byte)cur; lastChar2 = (Byte)cur; ='/guix/log/build-aux'>logtreecommitdiff
AgeCommit message (Expand)Author
2024-04-19maint: Generate doc/version[-LANG].texi using `mdate-from-git.scm'....Janneke Nieuwenhuizen
2024-04-19maint: Support `make doc-pot-update' from a tarball....Janneke Nieuwenhuizen
2024-04-14maint: Fix header....Janneke Nieuwenhuizen
2024-04-14maint: Use xgettext.scm wrapper to create .PO files reproducibly....Janneke Nieuwenhuizen
2024-01-05build: test-driver.scm: Set mode....Tomas Volf
2023-08-21maint: Add 'etc/hurd-manifest.scm'....Janneke Nieuwenhuizen
2023-07-25cuirass: Update hurd-manifest with newly supported packages....Janneke Nieuwenhuizen
2022-05-26cuirass: Create just as many threads as needed....Ludovic Courtès
2022-05-26cuirass: Fork inferior processes before creating threads....Ludovic Courtès
2022-05-20cuirass: Close each inferior upon completion....Ludovic Courtès