Fix CVE-2017-17969: https://sourceforge.net/p/p7zip/bugs/204/ https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-17969 Patch copied from Debian. Subject: Heap-based buffer overflow in 7zip/Compress/ShrinkDecoder.cpp Origin: vendor, https://sourceforge.net/p/p7zip/bugs/_discuss/thread/0920f369/27d7/attachment/CVE-2017-17969.patch Forwarded: https://sourceforge.net/p/p7zip/bugs/_discuss/thread/0920f369/#27d7 Bug: https://sourceforge.net/p/p7zip/bugs/204/ Bug-Debian: https://bugs.debian.org/888297 Bug-Debian-Security: https://security-tracker.debian.org/tracker/CVE-2017-17969 Author: Antoine Beaupré Reviewed-by: Salvatore Bonaccorso Last-Update: 2018-02-01 Applied-Upstream: 18.00-beta --- a/CPP/7zip/Compress/ShrinkDecoder.cpp +++ b/CPP/7zip/Compress/ShrinkDecoder.cpp @@ -121,8 +121,13 @@ HRESULT CDecoder::CodeReal(ISequentialIn { _stack[i++] = _suffixes[cur]; cur = _parents[cur]; + if (cur >= kNumItems || i >= kNumItems) + break; } - + + if (cur >= kNumItems || i >= kNumItems) + break; + _stack[i++] = (Byte)cur; lastChar2 = (Byte)cur; ' href='/guix/log/tests/go.scm'>logtreecommitdiff
AgeCommit message (Expand)Author
2021-09-28tests: go: Fix typo....Tobias Geerinckx-Rice
2021-09-01import: go: Improve error handling....zimoun
2021-07-18import: go: Upgrade go.mod parser....Sarah Morgensen
2021-07-17tests/go: Remove unused variable....Maxim Cournoyer
2021-05-05tests: go: Remove duplicate go-version->git-ref test....Maxim Cournoyer
2021-05-04tests: go: Fix typos in test descriptions....Tobias Geerinckx-Rice
2021-04-09import: go: Add an option to use pinned versions....Maxim Cournoyer
2021-04-09import: go: Improve synopsis and description parsing....Maxim Cournoyer
2021-03-10import: go: Compute the hash of Git checkouts....Ludovic Courtès
2021-03-10import: Add Go importer....Katherine Cox-Buday