From: Robert Luberda Date: Sat, 19 Nov 2016 08:48:08 +0100 Subject: Fix nullptr dereference (CVE-2016-9296) Patch taken from https://sourceforge.net/p/p7zip/bugs/185/ This patch file taken from Debian's patch set for p7zip --- CPP/7zip/Archive/7z/7zIn.cpp | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/CPP/7zip/Archive/7z/7zIn.cpp b/CPP/7zip/Archive/7z/7zIn.cpp index b0c6b98..7c6dde2 100644 --- a/CPP/7zip/Archive/7z/7zIn.cpp +++ b/CPP/7zip/Archive/7z/7zIn.cpp @@ -1097,7 +1097,8 @@ HRESULT CInArchive::ReadAndDecodePackedStreams( if (CrcCalc(data, unpackSize) != folders.FolderCRCs.Vals[i]) ThrowIncorrect(); } - HeadersSize += folders.PackPositions[folders.NumPackStreams]; + if (folders.PackPositions) + HeadersSize += folders.PackPositions[folders.NumPackStreams]; return S_OK; } Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/README
s/swh.scm?id=749b9582061f7d929be83a194040b63b41afec81'>swh: Adjust 'origin' test....
AgeCommit message (Expand)Author
2021-05-20The #guix channel is hosted by Libera Chat....Tobias Geerinckx-Rice
2020-10-23doc: Update README....Maxim Cournoyer
2020-10-22README: Refer to the manual for building from Git....Maxim Cournoyer
Ludovic Courtès
2019-09-02swh: Add hooks for rate limiting handling....Ludovic Courtès
2019-09-02tests: 'with-http-server' accepts multiple responses....Ludovic Courtès
2019-07-22swh: Add basic tests....Ludovic Courtès