From: Robert Luberda Date: Sat, 19 Nov 2016 08:48:08 +0100 Subject: Fix nullptr dereference (CVE-2016-9296) Patch taken from https://sourceforge.net/p/p7zip/bugs/185/ This patch file taken from Debian's patch set for p7zip --- CPP/7zip/Archive/7z/7zIn.cpp | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/CPP/7zip/Archive/7z/7zIn.cpp b/CPP/7zip/Archive/7z/7zIn.cpp index b0c6b98..7c6dde2 100644 --- a/CPP/7zip/Archive/7z/7zIn.cpp +++ b/CPP/7zip/Archive/7z/7zIn.cpp @@ -1097,7 +1097,8 @@ HRESULT CInArchive::ReadAndDecodePackedStreams( if (CrcCalc(data, unpackSize) != folders.FolderCRCs.Vals[i]) ThrowIncorrect(); } - HeadersSize += folders.PackPositions[folders.NumPackStreams]; + if (folders.PackPositions) + HeadersSize += folders.PackPositions[folders.NumPackStreams]; return S_OK; } bmit' value='switch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/system/vm.scm
AgeCommit message (Expand)Author
2024-04-17vm: Always use a native emulator in ‘guix system vm’....Ludovic Courtès
2024-03-31vm: If not the same local architecture, don't enable kvm....Zheng Junjie
2024-03-31vm: add arguments to use virt machine type for qemu-riscv64....Zheng Junjie
2024-03-31vm: When target riscv64-linux, use u-boot-qemu-riscv64-bootloader....Zheng Junjie
2024-03-31vm: use #$ for kernel-arguments....Zheng Junjie
2024-02-10services: Add ‘virtual-build-machine’ service....Ludovic Courtès
2024-02-10vm: Add ‘cpu-count’ field to <virtual-machine>....Ludovic Courtès
2024-02-10vm: Export <virtual-machine> accessors....Ludovic Courtès
2024-02-10vm: Add ‘date’ field to <virtual-machine>....Ludovic Courtès
2023-10-29system: vm: Include the cirrus driver in the initrd....Tobias Geerinckx-Rice
2023-10-01system: vm: Remove unused variable....Ludovic Courtès