This patch is taken from Debian and modified slightly Description: Phoning-home version checks should be disabled in Debian packages Author: Sandro Knauß Origin: debian Bug-debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=721341 Forwarded: not-needed Last-Update: 2014-02-17 --- This patch header follows DEP-3: http://dep.debian.net/deps/dep3/ --- a/src/libsync/configfile.cpp +++ b/src/libsync/configfile.cpp @@ -522,11 +522,14 @@ bool ConfigFile::skipUpdateCheck(const Q if (connection.isEmpty()) con = defaultConnection(); - QVariant fallback = getValue(skipUpdateCheckC(), con, false); + QVariant fallback = getValue(skipUpdateCheckC(), con, true); fallback = getValue(skipUpdateCheckC(), QString(), fallback); QVariant value = getPolicySetting(skipUpdateCheckC(), fallback); - return value.toBool(); + if ( !value.toBool() ) + qDebug() << "Guix has disabled the UpdateCheck mechanism."; + + return true; } void ConfigFile::setSkipUpdateCheck(bool skip, const QString &connection) --- a/src/gui/generalsettings.cpp +++ b/src/gui/generalsettings.cpp @@ -146,6 +149,7 @@ void GeneralSettings::loadMiscSettings() void GeneralSettings::slotUpdateInfo() { + /* Guix doesn't want an autoupdater if (ConfigFile().skipUpdateCheck() || !Updater::instance()) { // updater disabled on compile _ui->updaterWidget->setVisible(false); @@ -174,6 +178,9 @@ void GeneralSettings::slotUpdateInfo() _ui->updateChannel->setCurrentIndex(ConfigFile().updateChannel() == "beta" ? 1 : 0); connect(_ui->updateChannel, static_cast(&QComboBox::currentIndexChanged), this, &GeneralSettings::slotUpdateChannelChanged, Qt::UniqueConnection); + */ + //hide the update group box for Guix. + _ui->updaterWidget->setVisible(false); } void GeneralSettings::slotUpdateChannelChanged(int index) ='/guix/log/?id=b9bb50c608447170891af524a614748210deea89'>root/gnu/tests
AgeCommit message (Expand)Author
2016-07-12gnu: Switch to 'with-imported-modules'....Ludovic Courtès
2016-07-02tests: install: Adjust to new 'marionette-service-type' interface....Ludovic Courtès
2016-06-27tests: Add Avahi and NSS-mDNS test....Ludovic Courtès
2016-06-27tests: base: Add host name resolution tests....Ludovic Courtès
2016-06-23tests: basic: Don't hard-code the expected architecture name....Ludovic Courtès
2016-06-23tests: Installation test no longer requires KVM....Ludovic Courtès
2016-06-22services: Add 'mcron-service'....Ludovic Courtès
2016-06-20tests: Add a mechanism to describe and discover system tests....Ludovic Courtès
2016-06-20tests: Add system installation test....Ludovic Courtès
2016-06-20tests: base: Fully honor the OS passed to 'run-basic-test'....Ludovic Courtès
2016-06-20tests: Export 'run-basic-test'....Ludovic Courtès