This patch is taken from Debian and modified slightly Description: Phoning-home version checks should be disabled in Debian packages Author: Sandro Knauß Origin: debian Bug-debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=721341 Forwarded: not-needed Last-Update: 2014-02-17 --- This patch header follows DEP-3: http://dep.debian.net/deps/dep3/ --- a/src/libsync/configfile.cpp +++ b/src/libsync/configfile.cpp @@ -522,11 +522,14 @@ bool ConfigFile::skipUpdateCheck(const Q if (connection.isEmpty()) con = defaultConnection(); - QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, false); + QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, true); fallback = getValue(QLatin1String(skipUpdateCheckC), QString(), fallback); QVariant value = getPolicySetting(QLatin1String(skipUpdateCheckC), fallback); - return value.toBool(); + if ( !value.toBool() ) + qDebug() << "Guix has disabled the UpdateCheck mechanism."; + + return true; } void ConfigFile::setSkipUpdateCheck(bool skip, const QString &connection) --- a/src/gui/generalsettings.cpp +++ b/src/gui/generalsettings.cpp @@ -146,6 +149,7 @@ void GeneralSettings::loadMiscSettings() void GeneralSettings::slotUpdateInfo() { + /* Guix doesn't want an autoupdater if (ConfigFile().skipUpdateCheck() || !Updater::instance()) { // updater disabled on compile _ui->updaterWidget->setVisible(false); @@ -174,6 +178,9 @@ void GeneralSettings::slotUpdateInfo() _ui->updateChannel->setCurrentIndex(ConfigFile().updateChannel() == "beta" ? 1 : 0); connect(_ui->updateChannel, static_cast(&QComboBox::currentIndexChanged), this, &GeneralSettings::slotUpdateChannelChanged, Qt::UniqueConnection); + */ + //hide the update group box for Guix. + _ui->updaterWidget->setVisible(false); } void GeneralSettings::slotUpdateChannelChanged(int index) lass='path'>path: root/gnu/services/nix.scm
e mailmap....
AgeCommit message (Expand)Author
2020-07-22services: nix: Fix sandbox....Oleg Pykhalov
2020-06-25services: Add missing (ice-9 format) import....Ludovic Courtès
2019-06-12services: Import (srfi srfi-26) from the build side....Tobias Geerinckx-Rice
2019-06-11services: Add SRFI-26 to Nix activation gexp....Tobias Geerinckx-Rice
2019-06-10services: Add 'nix-service-type'....Oleg Pykhalov
Leo Famulari
2021-07-08mailmap: Update entries for Matthew James Kraai....Matthew James Kraai
2021-06-23gnu: Add Sollya....Eric Bavier
2021-04-21Update email address for Kei....Kei Kebreau
2020-05-15mailmap: Update for self....Mathieu Othacehe
2020-05-13mailmap: Update entries for Nikita....nikita
2020-03-28Update email address and Savannah handle for Amin Bandali....Amin Bandali
2020-02-09Update e-mail address for Jakob L. Kreuze....Tobias Geerinckx-Rice
2020-01-17Update email address for Amin Bandali....Amin Bandali
2019-12-19Update email for Brett Gilio....Brett Gilio
2019-12-18gnu: leocad: Update to 19.07.1....Eric Bavier