The 'intcompare' definition was causing a "cast from 'void*' to 'int' loses precision [-fpermissive]" error. It isn't used anywhere, so simply remove it. Same with 'findint' in texteditor.cc. Fix other "cast from ‘void*’ to ‘int’ loses precision" errors. --- a/kkstrtext-0.1/kkstrtext.cc 2005-01-31 18:13:24.000000000 -0600 +++ b/kkstrtext-0.1/kkstrtext.cc 2014-07-24 00:25:07.149305476 -0500 @@ -430,10 +430,6 @@ } } -int intcompare(void *s1, void *s2) { - return (int) s1 != (int) s2; -} - string i2str(int i) { char buf[64]; sprintf(buf, "%d", i); @@ -885,7 +881,7 @@ #ifdef HAVE_ICONV iconv_t cd = iconv_open(tocs.c_str(), fromcs.c_str()); - if(((int) cd) != -1) { + if(cd != (iconv_t) -1) { string r, text(atext); size_t inleft, outleft, soutleft; char *inbuf, *outbuf, *sinbuf, *soutbuf; --- a/kkconsui-0.1/src/texteditor.cc 2003-09-09 16:51:33.000000000 -0500 +++ b/kkconsui-0.1/src/texteditor.cc 2014-07-24 00:33:20.093279060 -0500 @@ -1939,10 +1939,6 @@ if(ur) delete ur; } -int texteditor::findint(void *p1, void *p2) { - return *(int *) p1 != (int) p2; -} - int texteditor::findhighline(void *p1, void *p2) { return *(int *) p1 != ((highline *) p2)->line; } --- a/src/streamtrack.cc 2006-05-11 12:45:20.000000000 -0500 +++ b/src/streamtrack.cc 2014-07-24 00:38:10.797263482 -0500 @@ -34,6 +34,7 @@ #include #include #include +#include #include od='get' action='/guix/log/.dir-locals.el'>
AgeCommit message (Expand)Author
2020-08-26.dir-locals.el: Add indentation rule for 'package/inherit'....Ludovic Courtès
2020-06-25deduplication: Use 'dynamic-wind' when changing permissions of the parent....Ludovic Courtès
2020-06-16channels: 'latest-channel-instance' authenticates Git checkouts....Ludovic Courtès
2020-06-10database: separate transaction-handling and retry-handling....Caleb Ristvedt
2020-06-10database: ensure update-or-insert is run within a transaction...Caleb Ristvedt
2020-06-10database: rewrite query procedures in terms of with-statement....Caleb Ristvedt
2020-06-06ui: 'display-search-results' automatically invokes the pager....Ludovic Courtès
2020-06-05git-authenticate: Add tests....Ludovic Courtès
2020-05-16gexp: Add 'let-system'....Ludovic Courtès
2020-03-22store: Add 'with-build-handler'....Ludovic Courtès
2020-03-12gexp: Add 'with-parameters'....Ludovic Courtès
2019-11-29ui: Factorize 'with-profile-lock'....Ludovic Courtès
2019-11-19pull: Acquire a lock for the target profile....Ludovic Courtès
2019-09-23git: Add 'commit-difference'....Ludovic Courtès
2019-06-05syscalls: Add 'with-file-lock' macro....Ludovic Courtès
2019-05-27publish: Add support for lzip....Ludovic Courtès