This patch removes the explicit reference to the 'perl' binary, such that OpenSSL does not retain a reference to Perl. The 'c_rehash' program is seldom used, but it is used nonetheless to create symbolic links to certificates, for instance in the 'nss-certs' package. --- openssl-1.0.2g/tools/c_rehash.in 2015-09-09 18:36:07.313316482 +0200 +++ openssl-1.0.2g/tools/c_rehash.in 2015-09-09 18:36:28.965458458 +0200 @@ -1,4 +1,6 @@ -#!/usr/local/bin/perl +eval '(exit $?0)' && eval 'exec perl -wS "$0" ${1+"$@"}' + & eval 'exec perl -wS "$0" $argv:q' + if 0; # Perl c_rehash script, scan all files in a directory # and add symbolic links to their hash values. 5656b049acbfd35ece10f5'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-09 13:14:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:36:24 +0300
commit5d46060db0c1e33b085656b049acbfd35ece10f5 (patch)
tree4678197b29ea22c6bb044fb35bdeea620fcb57ce /gnu
parent5e3050d06408421fe95e594f8fc5d1c70522e072 (diff)
downloadguix-5d46060db0c1e33b085656b049acbfd35ece10f5.tar.gz
guix-5d46060db0c1e33b085656b049acbfd35ece10f5.zip
gnu: rust-ref-cast-impl-0.2: Fix inputs.
* gnu/packages/crates-io.scm (rust-ref-cast-impl-0.2)[cargo-inputs]: Add rust-proc-macro2-1, rust-quote-1, rust-syn-1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index bbfe06ed6a..877a956005 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm