Fix a memory exhaustion bug in the key exchange, whereby an unauthenticated user could potentially consume 38400 MB of memory on the server: http://seclists.org/oss-sec/2016/q4/185 Patch adapted from upstream source repository: https://github.com/openssh/openssh-portable/commit/ec165c392ca54317dbe3064a8c200de6531e89ad From ec165c392ca54317dbe3064a8c200de6531e89ad Mon Sep 17 00:00:00 2001 From: "markus@openbsd.org" Date: Mon, 10 Oct 2016 19:28:48 +0000 Subject: [PATCH] upstream commit Unregister the KEXINIT handler after message has been received. Otherwise an unauthenticated peer can repeat the KEXINIT and cause allocation of up to 128MB -- until the connection is closed. Reported by shilei-c at 360.cn Upstream-ID: 43649ae12a27ef94290db16d1a98294588b75c05 --- kex.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/kex.c b/kex.c index 3f97f8c..6a94bc5 100644 --- a/kex.c +++ b/kex.c @@ -481,6 +481,7 @@ kex_input_kexinit(int type, u_int32_t seq, void *ctxt) if (kex == NULL) return SSH_ERR_INVALID_ARGUMENT; + ssh_dispatch_set(ssh, SSH2_MSG_KEXINIT, NULL); ptr = sshpkt_ptr(ssh, &dlen); if ((r = sshbuf_put(kex->peer, ptr, dlen)) != 0) return r; -- 2.10.1 on.ac?id=f7b1b22e4b0b5c6867bbfed362b0ebd4e5480507'>treecommitdiff
path: root/config-daemon.ac
AgeCommit message (Expand)Author
2019-11-27daemon: GC remove-unused-links phase uses 'statx' when available....Ludovic Courtès
2019-11-13daemon: Don't include <linux/fs.h>....Ludovic Courtès
2019-09-08daemon: Run 'guix substitute' directly and assume a single substituter....Ludovic Courtès
2019-09-08daemon: Run 'guix offload' directly....Ludovic Courtès
2019-09-08daemon: Run 'guix perform-download' directly....Ludovic Courtès
2019-09-08daemon: Run 'guix authenticate' directly....Ludovic Courtès
2019-09-08daemon: Invoke 'guix gc --list-busy' instead of 'list-runtime-roots'....Ludovic Courtès
2019-05-01build: Change default substitute server to "ci.guix.gnu.org"....Ludovic Courtès
2018-12-04build: Default to https://ci.guix.info for substitutes....Ludovic Courtès
2018-11-14daemon: Install 'authenticate' script under LIBEXECDIR/guix....Ludovic Courtès
2018-09-06build: Remove -L flag when $LIBGCRYPT_LIBDIR is empty....Ludovic Courtès