Author: Jan (janneke) Nieuwenhuizen" Not upstreamed. From 1ddae040d67e9a4ebcc3e1b95af1bff12c0f086b Mon Sep 17 00:00:00 2001 From: "Jan (janneke) Nieuwenhuizen" Date: Tue, 7 Apr 2020 17:41:05 +0200 Subject: [PATCH] Build fix for the Hurd. * gss-serv.c (ssh_gssapi_acquire_cred): Use HOST_NAME_MAX instead of MAXHOSTNAMELEN. --- gss-serv.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/gss-serv.c b/gss-serv.c index 1d47870e7..22081c6f1 100644 --- a/gss-serv.c +++ b/gss-serv.c @@ -107,7 +107,7 @@ ssh_gssapi_acquire_cred(Gssctxt *ctx) gss_create_empty_oid_set(&status, &oidset); gss_add_oid_set_member(&status, ctx->oid, &oidset); - if (gethostname(lname, MAXHOSTNAMELEN)) { + if (gethostname(lname, HOST_NAME_MAX)) { gss_release_oid_set(&status, &oidset); return (-1); } -- 2.26.0 t> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
AgeCommit message (Expand)Author
2022-05-30gnu: nss: Skip tests on riscv64-linux....* gnu/packages/nss.scm (nss)[arguments]: Skip tests when building for riscv64-linux. Efraim Flashner
2022-05-30gnu: nss: Adjust make-flags for riscv64-linux....* gnu/packages/nss.scm (nss)[arguments]: When building for riscv64-linux don't build the binaries with gtest. Efraim Flashner
2022-01-10gnu: nss: Update to 3.72....* gnu/packages/nss.scm (nss): Update to 3.72. Maxim Cournoyer
2021-12-17gnu: Remove unreferenced nss/fixed....* gnu/packages/nss.scm (nss/fixed): Remove variable. * gnu/packages/patches/nss-CVE-2021-43527.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Tobias Geerinckx-Rice
2021-12-16gnu: nss-certs: Avoid top-level reference to NSS....This is the only hammer I know for dealing with module cycles and effectively fixes, for example, ‘guix show nss’ today. It's also a very poor solution. * gnu/packages/certs.scm (nss-certs)[version, source]: Copy verbatim from the nss package rather than referring to it at the top level. Reported by several users of #guix. Tobias Geerinckx-Rice
2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès
2021-12-05Merge remote-tracking branch 'origin/master' into core-updates-frozenRicardo Wurmus
2021-12-03gnu: nss: Fix CVE-2021-43527 via graft....* gnu/packages/patches/nss-CVE-2021-43527.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/nss.scm (nss/fixed): New variable (nss)[replacement]: New field. Mark H Weaver
2021-12-01gnu: Add nspr@4.32....Required for icecat/icedove 91. * gnu/packages/nss.scm (nspr-4.32): New variable. Jonathan Brielmaier
2021-11-11gnu: nss: Update to 3.71....This is made in an attempt to get rid of non-deterministic test failures, namely: [ FAILED ] TlsConnectDatagram13.AeadLimit * gnu/packages/nss.scm (nss): Update comment about nss-certs. Update to 3.71. [phases]{check}: Update faketime date. [inputs]{sqlite}: Use the regular version. * gnu/packages/certs.scm (nss-certs): Inherit version and source from nss. Maxim Cournoyer
2021-11-11gnu: nspr: Normalize inputs....* gnu/packages/nss.scm (nspr)[inputs]: Remove conditional. Maxim Cournoyer