From 439266671bbd790b3cb339c157c87db382e85c96 Mon Sep 17 00:00:00 2001 From: Brice Waegeneire Date: Sat, 9 May 2020 15:52:06 +0200 Subject: [PATCH] Add RESTARTCMD for Guix System. --- openresolv need to know how to restart the nscd service, this patch teach it to do it on Guix System by using shepherd. resolvconf.in | 7 +++++++ 1 file changed, 7 insertions(+) diff --git a/resolvconf.in b/resolvconf.in index aa77ffe..921882e 100644 --- a/resolvconf.in +++ b/resolvconf.in @@ -375,6 +375,13 @@ detect_init() fi' elif [ -d /etc/dinit.d ] && command -v dinitctl >/dev/null 2>&1; then RESTARTCMD='dinitctl --quiet restart --ignore-unstarted $1' + elif [ -e /gnu/store ] && [ -e /run/current-system/profile ]; then + # Guix System + RESTARTCMD=' + if /run/current-system/profile/bin/herd status $1 2>&1 + then + /run/current-system/profile/bin/herd restart $1 + fi' else for x in /etc/init.d/rc.d /etc/rc.d /etc/init.d; do [ -d $x ] || continue -- 2.41.0 ='/guix/about/'>aboutsummaryrefslogtreecommitdiff
path: root/tests/store.scm
AgeCommit message (Expand)Author
2021-03-18tests: Make the STORE test more robust in a "pure" environment....Leo Famulari
2021-01-22store: Add 'find-roots' RPC....Ludovic Courtès
2020-12-19tests: Make sure substituted items are deduplicated....Ludovic Courtès
2020-12-19tests: Check the mtime and permissions of substituted items....Ludovic Courtès
2020-12-19tests: Check the build trace for hash mismatches on substitutes....Ludovic Courtès
2020-09-14tests: Remove one 'delete-paths' call in 'tests/store.scm'....Ludovic Courtès
2020-09-14daemon: Spawn 'guix authenticate' once for all....Ludovic Courtès
2020-09-11store: Test 'import-paths' with unauthorized and unsigned nar bundles....Ludovic Courtès
2020-08-28store: 'with-store' returns as many values as its body....Ludovic Courtès
2020-06-27daemon: Recognize SHA3 and BLAKE2s....Ludovic Courtès
2020-05-22packages: Introduce <content-hash> and use it in <origin>....Ludovic Courtès
2020-05-22tests: Test 'add-to-store' with several hash algorithms....Ludovic Courtès
2020-05-14store: 'mapm/accumulate-builds' preserves '%current-target-system'....Ludovic Courtès
2020-04-04store: 'with-store' doesn't close the store upon abort....Ludovic Courtès
2020-03-29store: Add 'map/accumulate-builds'....Ludovic Courtès
2020-03-22store: Add 'with-build-handler'....Ludovic Courtès