PSM2 is the only valid implementation for OmniPath (OPA). UCX also supports OmniPath, but it does so via Verbs, thus getting much lower performance (typically 3 GiB/s instead of 10 GiB/s). To work around that, give the mtl_psm2 component a higher priority than the pml_ucx component. See . --- openmpi-4.0.2/ompi/mca/mtl/psm2/mtl_psm2_component.c 2019-11-15 17:06:15.142076840 +0100 +++ openmpi-4.0.2/ompi/mca/mtl/psm2/mtl_psm2_component.c 2019-11-15 17:06:22.242009379 +0100 @@ -126,7 +126,7 @@ ompi_mtl_psm2_component_register(void) setenv("PSM2_DEVICES", "self,shm", 0); } - param_priority = 40; + param_priority = 55; (void) mca_base_component_var_register (&mca_mtl_psm2_component.super.mtl_version, "priority", "Priority of the PSM2 MTL component", MCA_BASE_VAR_TYPE_INT, NULL, 0, 0, Likewise for PSM: we want InfiniPath to be taken care of by PSM, not by UCX, since UCX achieves worse performance. --- openmpi-4.0.2/ompi/mca/mtl/psm/mtl_psm_component.c +++ openmpi-4.0.2/ompi/mca/mtl/psm/mtl_psm_component.c @@ -92,7 +92,7 @@ ompi_mtl_psm_component_register(void) /* set priority high enough to beat ob1's default */ - param_priority = 30; + param_priority = 54; (void) mca_base_component_var_register (&mca_mtl_psm_component.super.mtl_version, "priority", "Priority of the PSM MTL component", MCA_BASE_VAR_TYPE_INT, NULL, 0, 0, dbef037ff48460ec8f7bb4dbb3139c74403a9378'/>
path: root/gnu/packages/mes.scm
AgeCommit message (Expand)Author
2019-11-25gnu: mes: Update to 0.21....* gnu/packages/mes.scm (mes): Update to 0.21. Jan Nieuwenhuizen
2019-11-14gnu: Add m2-planet....* gnu/packages/mes.scm (m2-planet): New variable. Jan Nieuwenhuizen
2019-10-12gnu: mescc-tools: Use 'git-fetch'....* gnu/packages/mes.scm (mescc-tools-0.5.2)[source]: Use 'git-fetch'. (mescc-tools)[source]: Likewise. Ludovic Courtès
2019-09-29bootstrap: mes: Add mes-0.19....* gnu/packages/mes.scm (mes-0.19): New variable. (mes): Inherit it. * gnu/packages/make-bootstrap.scm (%mes-minimal): Likewise. Jan Nieuwenhuizen
2019-09-29bootstrap: mescc-tools: Use mescc-tools-0.5.2, mescc-tools....* gnu/packages/mes.scm (mescc-tools-0.5.2): New variable; rename from mescc-tools. (mescc-tools): Rename from mescc-tools-0.6.1. Fix build. * gnu/packages/make-bootstrap.scm (%mescc-tools-static): Inherit fixed mescc-tools-0.5.2. Jan Nieuwenhuizen
2019-09-17Merge branch 'master' into core-updatesLudovic Courtès
2019-09-09gnu: mes: Update to 0.20....* gnu/packages/mes.scm (mes): Update to 0.20. Use nyacc-0.99.0. Jan Nieuwenhuizen
2019-09-09gnu: mescc-tools: Update to 0.6.1....* gnu/packages/mes.scm (mescc-tools): Update to 0.6.1. Jan Nieuwenhuizen
2019-09-09gnu: nyacc: Update to 0.99.0....* gnu/packages/mes.scm (nyacc): Update to 0.99.0. Jan Nieuwenhuizen
2019-06-13Merge branch 'master' into core-updatesLudovic Courtès
2019-06-13gnu: nyacc: Add 0.94.0....* gnu/packages/mes.scm (nyacc): Rename to... (nyacc-0.86): ... this. (nyacc): New variable. (mes)[propagated-inputs]: Use NYACC-0.86 instead of NYACC. Ludovic Courtès
2019-05-25Merge branch 'staging' into core-updatesMarius Bakke
2019-05-21gnu: mes: Prepare for non-x86 architectures....* gnu/packages/mes.scm (mes)[native-inputs]: Change i686-linux-binutils and i686-linux-gcc conditional inclusion. Danny Milosavljevic