PSM2 is the only valid implementation for OmniPath (OPA). UCX also supports OmniPath, but it does so via Verbs, thus getting much lower performance (typically 3 GiB/s instead of 10 GiB/s). To work around that, give the mtl_psm2 component a higher priority than the pml_ucx component. See . --- openmpi-4.0.2/ompi/mca/mtl/psm2/mtl_psm2_component.c 2019-11-15 17:06:15.142076840 +0100 +++ openmpi-4.0.2/ompi/mca/mtl/psm2/mtl_psm2_component.c 2019-11-15 17:06:22.242009379 +0100 @@ -126,7 +126,7 @@ ompi_mtl_psm2_component_register(void) setenv("PSM2_DEVICES", "self,shm", 0); } - param_priority = 40; + param_priority = 55; (void) mca_base_component_var_register (&mca_mtl_psm2_component.super.mtl_version, "priority", "Priority of the PSM2 MTL component", MCA_BASE_VAR_TYPE_INT, NULL, 0, 0, Likewise for PSM: we want InfiniPath to be taken care of by PSM, not by UCX, since UCX achieves worse performance. --- openmpi-4.0.2/ompi/mca/mtl/psm/mtl_psm_component.c +++ openmpi-4.0.2/ompi/mca/mtl/psm/mtl_psm_component.c @@ -92,7 +92,7 @@ ompi_mtl_psm_component_register(void) /* set priority high enough to beat ob1's default */ - param_priority = 30; + param_priority = 54; (void) mca_base_component_var_register (&mca_mtl_psm_component.super.mtl_version, "priority", "Priority of the PSM MTL component", MCA_BASE_VAR_TYPE_INT, NULL, 0, 0, put type='hidden' name='id' value='03592a6f882f5b4309f77c3dc3e65559d7b7cb75'/>
path: root/gnu/packages/calendar.scm
AgeCommit message (Expand)Author
2018-10-12gnu: khal: Update to 0.9.10....Leo Famulari
2018-05-31gnu: khal: Use INVOKE....Tobias Geerinckx-Rice
2018-05-29gnu: khal: Update to 0.9.9....Leo Famulari
2018-03-12gnu: libical: Update to 3.0.3....Marius Bakke
2018-02-20gnu: libical: Update to 3.0.2....Marius Bakke
2018-02-20gnu: calendar.scm: Use license: prefix....Marius Bakke
2017-12-19gnu: Remove redundant cmake libdir configure flags....Efraim Flashner
2017-11-19Merge branch 'master' into core-updatesMarius Bakke
2017-11-18gnu: Move date/time packages from python.scm to time.scm....Ricardo Wurmus
2017-11-17gnu: Move testing packages from python.scm to check.scm....Ricardo Wurmus
2017-10-19gnu: Remove python-pytest@2....Marius Bakke
2017-10-07gnu: khal: Update to 0.9.8....Leo Famulari
2017-09-28gnu: libical: Fix libdir install path....Efraim Flashner