Fix a time bomb present in the OpenJDK tools. --- a/jdk/make/src/classes/build/tools/generatecurrencydata/GenerateCurrencyData.java +++ b/jdk/make/src/classes/build/tools/generatecurrencydata/GenerateCurrencyData.java @@ -285,7 +285,7 @@ public class GenerateCurrencyData { String timeString = currencyInfo.substring(4, length - 4); long time = format.parse(timeString).getTime(); if (Math.abs(time - System.currentTimeMillis()) > ((long) 10) * 365 * 24 * 60 * 60 * 1000) { - throw new RuntimeException("time is more than 10 years from present: " + time); + System.err.println("note: time is more than 10 years from \"present\": " + time); } specialCaseCutOverTimes[specialCaseCount] = time; specialCaseOldCurrencies[specialCaseCount] = oldCurrency; input type='submit' value='switch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/guix-package-aliases.sh
ler: Render the final configuration with (guix read-print)....
AgeCommit message (Expand)Author
2020-10-02guix build: Record package transformations in manifest entries....Ludovic Courtès
2020-09-28tests: Simplify shell exit status negation;...Eric Bavier
Ludovic Courtès
2022-02-02installer: Use system-wide guix for system init....Josselin Poiret
2022-02-02installer: Make dump archive creation optional and selective....Josselin Poiret
2022-02-02installer: Use dynamic-wind to setup installer....Josselin Poiret
2022-02-02installer: Add nano to PATH....Josselin Poiret
2022-02-02installer: Add installer-specific run command process....Josselin Poiret
2022-02-02installer: Use new installer-log-line everywhere....Josselin Poiret
2022-02-02installer: Use define instead of let at top-level....Josselin Poiret
2022-02-02installer: Add crash dump upload support....Mathieu Othacehe
2022-01-14installer: Check if ci.guix.gnu.org can be reached....Mathieu Othacehe
2021-09-23installer: Support XFS....Tobias Geerinckx-Rice
2021-01-12installer: Fix crash in parameters menu....Mathieu Othacehe