The following patch prevents build failures due to comparisons between
a pointer and an integer. It has been adapted from openjdk@10.
diff -u -r openjdk-9.alt/hotspot/src/share/vm/memory/virtualspace.cpp openjdk-9/hotspot/src/share/vm/memory/virtualspace.cpp
--- openjdk-9.alt/hotspot/src/share/vm/memory/virtualspace.cpp 2023-04-05 13:46:58.841965513 +0200
+++ openjdk-9/hotspot/src/share/vm/memory/virtualspace.cpp 2023-04-05 13:48:43.902387837 +0200
@@ -581,7 +581,7 @@
assert(markOopDesc::encode_pointer_as_mark(&_base[size])->decode_pointer() == &_base[size],
"area must be distinguishable from marks for mark-sweep");
- if (base() > 0) {
+ if (base() != NULL) {
MemTracker::record_virtual_memory_type((address)base(), mtJavaHeap);
}
}
diff -u -r openjdk-9.alt/hotspot/src/share/vm/opto/lcm.cpp openjdk-9/hotspot/src/share/vm/opto/lcm.cpp
--- openjdk-9.alt/hotspot/src/share/vm/opto/lcm.cpp 2023-04-05 13:46:58.849965545 +0200
+++ openjdk-9/hotspot/src/share/vm/opto/lcm.cpp 2023-04-05 13:47:53.566187260 +0200
@@ -39,7 +39,7 @@
// Check whether val is not-null-decoded compressed oop,
// i.e. will grab into the base of the heap if it represents NULL.
static bool accesses_heap_base_zone(Node *val) {
- if (Universe::narrow_oop_base() > 0) { // Implies UseCompressedOops.
+ if (Universe::narrow_oop_base() != NULL) { // Implies UseCompressedOops.
if (val && val->is_Mach()) {
if (val->as_Mach()->ideal_Opcode() == Op_DecodeN) {
// This assumes all Decodes with TypePtr::NotNull are matched to nodes that
ackages/aux-files/linux-libre/6.11-arm.conf?id=e00c621cbbf58a54ca2dd0c7075f154af26bcd54'>diff
|
Age | Commit message (Expand) | Author |
2024-10-20 | gnu: Add linux-libre 6.11.4....* gnu/packages/linux.scm (linux-libre-6.11-version, linux-libre-6.11-gnu-revision,
deblob-scripts-6.11, linux-libre-6.11-pristine-source, linux-libre-6.11-source,
linux-libre-headers-6.11, linux-libre-6.11): New variables.
* gnu/packages/aux-files/linux-libre/6.11-arm.conf,
gnu/packages/aux-files/linux-libre/6.11-arm64.conf,
gnu/packages/aux-files/linux-libre/6.11-i686.conf,
gnu/packages/aux-files/linux-libre/6.11-riscv.conf,
gnu/packages/aux-files/linux-libre/6.11-x86.conf: New files.
* Makefile.am (AUX_FILES): Add them.
Co-authored-by: Ahmad Draidi <a.r.draidi@redscript.org>
Change-Id: I35bad9fbea9f568e60e7f24c95f85c240ef96277
Signed-off-by: Leo Famulari <leo@famulari.name>
| Wilko Meyer |