Patch inspired by file comparison with openjdk@19. diff -u -r openjdk-10.alt/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c openjdk-10/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c --- openjdk-10.alt/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c 2023-04-05 15:03:00.070787628 +0200 +++ openjdk-10/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c 2023-04-05 15:29:51.379824348 +0200 @@ -67,8 +67,17 @@ longjmp(context, 1); } -void set_signal_handler() { - static char altstack[SIGSTKSZ]; +static char* altstack = NULL; + + void set_signal_handler() { + if (altstack == NULL) { + // Dynamically allocated in case SIGSTKSZ is not constant + altstack = (char*)malloc(SIGSTKSZ); + if (altstack == NULL) { + fprintf(stderr, "Test ERROR. Unable to malloc altstack space\n"); + exit(7); + } + } stack_t ss = { .ss_size = SIGSTKSZ, /> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/instrumentation.scm
AgeCommit message (Expand)Author
2022-01-20gnu: Add uftrace....* gnu/packages/instrumentation.scm: (uftrace): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Olivier Dion
2022-01-20gnu: Add flamegraph....* gnu/packages/instrumentation.scm (flamegraph): New variable. Olivier Dion
2021-12-30gnu: lttng-tools: Update to 2.13.2....* gnu/packages/instrumentation.scm (lttng-tools): Update to 2.13.2. Tobias Geerinckx-Rice
2021-12-30gnu: lttng-ust: Update to 2.13.1....* gnu/packages/instrumentation.scm (lttng-ust): Update to 2.13.1. Tobias Geerinckx-Rice
2021-12-22gnu: Enable babeltrace Python's bindings....* gnu/packages/instrumentation.scm (babeltrace) [tests?]: Set to false. [configure-flags]: Enable Python's plugins and bindings. [make-flags]: Add output's /lib to linker rpath. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Olivier Dion
2021-12-18gnu: babeltrace, lttng-tools: Simplify inputs....* gnu/packages/instrumentation.scm (babeltrace, lttng-tools): Simplify inputs. Ludovic Courtès
2021-12-18gnu: Move instrumentation tools to instrumentation module....* gnu/packages/linux.scm (lttng-ust, lttng-tools, babeltrace): Move to ... * gnu/packages/instrumentation.scm: ... here. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Olivier Dion
2021-12-18gnu: Add Dyninst....* gnu/packages/instrumentation.scm: New file * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Olivier Dion