Patch inspired by file comparison with openjdk@19. diff -u -r openjdk-10.alt/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c openjdk-10/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c --- openjdk-10.alt/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c 2023-04-05 15:03:00.070787628 +0200 +++ openjdk-10/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c 2023-04-05 15:29:51.379824348 +0200 @@ -67,8 +67,17 @@ longjmp(context, 1); } -void set_signal_handler() { - static char altstack[SIGSTKSZ]; +static char* altstack = NULL; + + void set_signal_handler() { + if (altstack == NULL) { + // Dynamically allocated in case SIGSTKSZ is not constant + altstack = (char*)malloc(SIGSTKSZ); + if (altstack == NULL) { + fprintf(stderr, "Test ERROR. Unable to malloc altstack space\n"); + exit(7); + } + } stack_t ss = { .ss_size = SIGSTKSZ, d Guix
aboutsummaryrefslogtreecommitdiff
path: root/nix
AgeCommit message (Expand)Author
2018-04-19guix-daemon: Disable garbage collection for remote connections....Roel Janssen
2018-03-30daemon: Remove unused schema upgrade code....Ludovic Courtès
2018-03-30daemon: Remove dead code....Ludovic Courtès
2018-01-11daemon: Always try to execute the builder regardless of the platform....Ludovic Courtès
2018-01-07daemon: Make libbz2 an optional dependency....Ludovic Courtès
2018-01-07daemon: Add gzip log compression....Ludovic Courtès
2017-12-31list-runtime-root: Fix off-by-one in 'strip-drop' call....Ludovic Courtès
2017-11-26list-runtime-roots: Ignore ESRCH while reading from /proc....Ludovic Courtès
2017-11-12list-runtime-roots: Ignore PIDs we cannot access....Ludovic Courtès
2017-11-12list-runtime-roots: Canonicalize store items....Ludovic Courtès
2017-11-12list-runtime-roots: Do not use 'lsof'....Ludovic Courtès