--- orig/jdk-6fa770f9f8ab/make/GenerateLinkOptData.gmk 2022-04-04 17:16:29.365930149 +0200
+++ jdk-6fa770f9f8ab/make/GenerateLinkOptData.gmk 2022-04-04 17:16:54.954624358 +0200
@@ -61,11 +61,12 @@
$(call MakeDir, $(LINK_OPT_DIR))
$(call LogInfo, Generating $(patsubst $(OUTPUTDIR)/%, %, $@))
$(call LogInfo, Generating $(patsubst $(OUTPUTDIR)/%, %, $(JLI_TRACE_FILE)))
- $(FIXPATH) $(INTERIM_IMAGE_DIR)/bin/java -XX:DumpLoadedClassList=$@ \
+ $(FIXPATH) $(INTERIM_IMAGE_DIR)/bin/java -XX:DumpLoadedClassList=$@.tmp \
-Djava.lang.invoke.MethodHandle.TRACE_RESOLVE=true \
-cp $(SUPPORT_OUTPUTDIR)/classlist.jar \
build.tools.classlist.HelloClasslist \
$(LOG_DEBUG) 2>&1 > $(JLI_TRACE_FILE)
+ sort $@.tmp > $@
# The jli trace is created by the same recipe as classlist. By declaring these
# dependencies, make will correctly rebuild both jli trace and classlist
--- orig/jdk-6fa770f9f8ab/make/gendata/Gendata-jdk.compiler.gmk 2022-04-13 19:24:10.191682716 +0200
+++ jdk-6fa770f9f8ab/make/gendata/Gendata-jdk.compiler.gmk 2022-04-13 20:58:57.891368216 +0200
@@ -83,6 +83,8 @@
$(CT_MODULESOURCEPATH) \
$(CT_MODULES) \
>$(@D)/A/system-modules
+ # Make files reproducible
+ find $(@D) -exec $(TOUCH) -h -c -t 197001010000.01 {} \;
$(TOUCH) $@
# Can't generate ct.sym directly into modules libs as the SetupJarArchive macro
splay-managers.scm?id=b5ed7b2201b8ca25f90a53e07edd529b4cba2d7c'>commitdiff
|
Age | Commit message (Expand) | Author |
2023-07-09 | gnu: lightdm: Apply patch to fix VNC server address binding ordering....* gnu/packages/patches/lightdm-vnc-ipv6.patch: New patch file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/display-managers.scm (lightdm): Apply it.
* gnu/tests/lightdm.scm (run-lightdm-test): Remove comment and expected fail
directive for the "can connect to TCP port 5900 on IPv6" test.
Suggested-by: Bruno Victal <mirai@makinata.eu>
| Maxim Cournoyer |
2023-04-30 | gnu: slim: Update homepage....Moved to github, according to https://www.berlios.de/software/slim/.
* gnu/packages/display-managers.scm (slim) [home-page]: update URL.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Brian Cully |
2023-04-30 | gnu: slim: Fix build failure with GCC-11...GCC-11 sniffed out a long-standing bug where a pointer was being tested for a
negative value, which is impossible. Instead, check for NULL, which is how the
error result is actually returned.
See https://github.com/iwamatsu/slim/issues/14 for details.
Fixes <https://issues.guix.gnu.org/63155>.
* gnu/packages/display-managers.scm (slim) [fix-0-pointer-comparison]: new
phase
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Brian Cully |