Specifying the `async_mode` parameter seems to have been a workaround for packaging on Windows and macOS. If not given, flask_socketio.SocketIO will probe for an available asynchronous model, e.g. `eventlet`, and otherwise gets stuck if `gevent-socketio` is not available. c.f. https://github.com/onionshare/onionshare/commit/ec7fa4ef16c9e1ba6028ee927c23f76c399a17a6 and https://github.com/onionshare/onionshare/issues/1510 diff --git a/cli/onionshare_cli/web/web.py b/cli/onionshare_cli/web/web.py index 64844b5..7e1b095 100644 --- a/cli/onionshare_cli/web/web.py +++ b/cli/onionshare_cli/web/web.py @@ -164,10 +164,10 @@ class Web: elif self.mode == "chat": if self.common.verbose: self.socketio = SocketIO( - async_mode="gevent", logger=True, engineio_logger=True + logger=True, engineio_logger=True ) else: - self.socketio = SocketIO(async_mode="gevent") + self.socketio = SocketIO() self.socketio.init_app(self.app) self.chat_mode = ChatModeWeb(self.common, self) cdcc64dfd'>refslogtreecommitdiff
path: root/gnu/packages/ncurses.scm
AgeCommit message (Expand)Author
2019-03-30gnu: Use 'this-package' as a native input instead of 'self-native-input?'....Ludovic Courtès
2019-03-18Correct name and email address for ng0....ng0
2019-02-18gnu: dialog: Download sources over HTTPS....Tobias Geerinckx-Rice
2019-02-18gnu: dialog: Update to 1.3-20190211....Tobias Geerinckx-Rice
2018-08-11Migrate search.cpan.org home pages to metacpan.org....Tobias Geerinckx-Rice
2018-08-11gnu: dialog: Update to 1.3-20180621....Tobias Geerinckx-Rice
2018-04-22gnu: ncurses: Do not use "install -s" when cross-compiling....Ludovic Courtès
2018-03-20Merge branch 'master' into core-updatesMark H Weaver
2018-03-20Correct name and Email for ng0....ng0