Specifying the `async_mode` parameter seems to have been a workaround for packaging on Windows and macOS. If not given, flask_socketio.SocketIO will probe for an available asynchronous model, e.g. `eventlet`, and otherwise gets stuck if `gevent-socketio` is not available. c.f. https://github.com/onionshare/onionshare/commit/ec7fa4ef16c9e1ba6028ee927c23f76c399a17a6 and https://github.com/onionshare/onionshare/issues/1510 diff --git a/cli/onionshare_cli/web/web.py b/cli/onionshare_cli/web/web.py index 64844b5..7e1b095 100644 --- a/cli/onionshare_cli/web/web.py +++ b/cli/onionshare_cli/web/web.py @@ -164,10 +164,10 @@ class Web: elif self.mode == "chat": if self.common.verbose: self.socketio = SocketIO( - async_mode="gevent", logger=True, engineio_logger=True + logger=True, engineio_logger=True ) else: - self.socketio = SocketIO(async_mode="gevent") + self.socketio = SocketIO() self.socketio.init_app(self.app) self.chat_mode = ChatModeWeb(self.common, self) ref='/guix/'>summaryrefslogtreecommitdiff
path: root/tests/guix-shell-export-manifest.sh
AgeCommit message (Collapse)Author
2022-06-16shell: Fix '--export-manifest' for cached profiles and when '-p' is used.Ludovic Courtès
Fixes <https://issues.guix.gnu.org/55521>. * guix/scripts/shell.scm (export-manifest): When computing 'manifest', honor the 'profile key. * tests/guix-shell-export-manifest.sh: Add test.
2022-06-01shell: '--export-manifest -D x -D y' generates a valid manifest.Ludovic Courtès
* guix/scripts/shell.scm (manifest->code*): Add missing 'list' in generated 'concatenate-manifests' call. * tests/guix-shell-export-manifest.sh: Add test.
2022-04-08tests: 'guix shell --export-manifest' test no longer needs networking.Ludovic Courtès
* tests/guix-shell-export-manifest.sh: Use '--with-input' rather than '--with-latest' as the latter would crash in the absence of network access.
2022-04-04shell: Add '--export-manifest'.Ludovic Courtès
* guix/scripts/shell.scm (show-help, %options): Add '--export-manifest'. (manifest-entry-version-prefix, manifest->code*) (export-manifest): New procedures. (guix-shell): Honor '--export-manifest'. * tests/guix-shell-export-manifest.sh: New file. * Makefile.am (SH_TESTS): Add it. * doc/guix.texi (Invoking guix shell): Document '--export-manifest'. (Invoking guix environment): Link to it. (Invoking guix pack): Likewise.