From 2e7e254160506dc00f1beabf170512a8e932934b Mon Sep 17 00:00:00 2001 From: Julien Lepiller Date: Sat, 31 Dec 2016 15:43:38 +0100 Subject: [PATCH] fix build date in binary --- src/magic/omake_gen_magic.ml | 12 ++---------- 1 file changed, 2 insertions(+), 10 deletions(-) diff --git a/src/magic/omake_gen_magic.ml b/src/magic/omake_gen_magic.ml index b2419ba..fad52f5 100644 --- a/src/magic/omake_gen_magic.ml +++ b/src/magic/omake_gen_magic.ml @@ -150,7 +150,7 @@ let ir_magic = "%s" let obj_magic = "%s" let lib_dir = "%s" let version = "%s" -let version_message = "OMake %s:\\n\\tbuild [%s %s %d %02d:%02d:%02d %d]\\n\\ton %s" +let version_message = "OMake %s" |} default_save_interval digest_len @@ -160,15 +160,7 @@ let version_message = "OMake %s:\\n\\tbuild [%s %s %d %02d:%02d:%02d %d]\\n\\ton (digest_files ".omo.magic" ".omo" omo_files) (String.escaped libdir) (String.escaped (shorten_version version)) - (String.escaped version) - [|"Sun"; "Mon"; "Tue"; "Wed"; "Thu"; "Fri"; "Sat"|].(tm.tm_wday) - [|"Jan"; "Feb"; "Mar"; "Apr"; "May"; "Jun"; "Jul"; "Aug"; "Sep"; "Oct"; "Nov"; "Dec"|].(tm.tm_mon) - tm.tm_mday - tm.tm_hour - tm.tm_min - tm.tm_sec - (tm.tm_year + 1900) - (String.escaped (Unix.gethostname ())); + (String.escaped version); List.iter (fun (name,value) -> Printf.fprintf buf "let %s = %S\n" name value -- 2.11.0 .sh?id=c7210b9613372dffa7b1926832b1ec1ff97d4bbf'>diff
path: root/tests/guix-gc.sh
AgeCommit message (Collapse)Author
2019-04-10guix gc: Add '--list-roots'.Ludovic Courtès
* guix/scripts/gc.scm (show-help, %options): Add '--list-roots'. (guix-gc)[list-roots]: New procedure. Handle '--list-roots'. * tests/guix-gc.sh: Test it. * doc/guix.texi (Invoking guix gc): Document it.
2018-03-27guix gc: Add '--derivers'.Ludovic Courtès
* guix/scripts/gc.scm (show-help, %options): Add '--derivers'. (guix-gc): Handle 'list-derivers'. * tests/guix-gc.sh: Add test. * doc/guix.texi (Invoking guix gc): Document it.
2017-12-18guix gc: '--verify=foo' is reported as an error.Ludovic Courtès
Fixes <https://bugs.gnu.org/29761>. Reported by Martin Castillo <castilma@uni-bremen.de>. * guix/scripts/gc.scm (argument->verify-options): New procedure. (%options) ["verify"]: Adjust to use it. * tests/guix-gc.sh: Add test.
2017-11-13tests: 'guix-gc.sh' passes even when 'out' or 'drv' are defined as env vars.Ludovic Courtès
This fixes a test failure exhibited by fb17a89912c2a3738dae716e30481c11e1c6f0ac whereby assignments to 'out' in guix-gc.sh would go to the 'out' environment variable, when it exists, which in turn prevents garbage collection of $out. * tests/guix-gc.sh: Add 'unset' invocations.