Avoid multiply-defined symbols that lead to link errors such as:
gcc -O2 -fno-strict-aliasing -fwrapv -Wall -fno-tree-vrp -g -D_FILE_OFFSET_BITS=64 -D_REENTRANT -DCAML_NAME_SPACE -Wl,-E -o ocamlruni prims.o libcamlruni.a -lm -ldl -lpthread
ld: libcamlruni.a(backtrace.i.o):/tmp/guix-build-ocaml-4.07.1.drv-0/ocaml-4.07.1/byterun/backtrace.c:31: multiple definition of `caml_debug_info'; libcamlruni.a(backtrace_prim.i.o):/tmp/guix-build-ocaml-4.07.1.drv-0/ocaml-4.07.1/byterun/backtrace_prim.c:47: first defined here
diff --git a/asmrun/startup.c b/asmrun/startup.c
index 070f0c6..cf8a56f 100644
--- a/asmrun/startup.c
+++ b/asmrun/startup.c
@@ -44,7 +44,6 @@
#endif
extern int caml_parser_trace;
-CAMLexport header_t caml_atom_table[256];
char * caml_code_area_start, * caml_code_area_end;
struct ext_table caml_code_fragments_table;
diff --git a/byterun/backtrace.c b/byterun/backtrace.c
index 8dfe9b7..9cc9e72 100644
--- a/byterun/backtrace.c
+++ b/byterun/backtrace.c
@@ -28,7 +28,7 @@
#include "caml/fail.h"
/* The table of debug information fragments */
-struct ext_table caml_debug_info;
+static struct ext_table caml_debug_info;
CAMLexport int32_t caml_backtrace_active = 0;
CAMLexport int32_t caml_backtrace_pos = 0;
diff --git a/byterun/backtrace_prim.c b/byterun/backtrace_prim.c
index e69b256..d794f73 100644
--- a/byterun/backtrace_prim.c
+++ b/byterun/backtrace_prim.c
@@ -44,7 +44,7 @@
#include "caml/backtrace_prim.h"
/* The table of debug information fragments */
-struct ext_table caml_debug_info;
+static struct ext_table caml_debug_info;
CAMLexport char_os * caml_cds_file = NULL;
'0726d4ea7cb882dd1d3887303e260aba433dd1ef'/>
log msg
author
committer
range
Age Commit message (Expand ) Author
2017-11-16 gnu: wget: Add wget2. ...* gnu/packages/wget.scm (wget2): New variable.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Rutger Helling
2017-10-26 gnu: wget: Update to 1.19.2 [fixes CVE-2017-13089 and CVE-2017-13090]. ...* gnu/packages/wget.scm (wget): Update to 1.19.2.
[source](uri): Change to '.lz' tarball.
[source](patches): Remove.
[native-inputs]: Add LZIP.
* gnu/packages/patches/wget-CVE-2017-6508.patch,
gnu/packages/patches/wget-fix-504-test-timeout.patch,
gnu/packages/patches/wget-perl-5.26.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Remove them.
Marius Bakke
2017-07-08 gnu: wget: Update comment about test failures. ...* gnu/packages/wget.scm (wget)[arguments]: Update comment.
Ludovic Courtès
2017-07-07 gnu: wget: Fix compilation with Perl 5.26; skip faulty tests. ...* gnu/packages/wget.scm (wget)[arguments]: New field.
[source](patches): Add "wget-perl-5.26.patch".
* gnu/packages/patches/wget-perl-5.26.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
Ludovic Courtès
2017-03-20 gnu: wget: Fix test-504 failures. ...* gnu/packages/wget.scm (wget)[source]: Add patch.
* gnu/packages/patches/wget-fix-504-test-timeout.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
Efraim Flashner
2017-03-10 gnu: wget: Fix CVE-2017-6508. ...* gnu/packages/patches/wget-CVE-2017-6508.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/wget.scm (wget)[source]: Use it.
Leo Famulari
2017-02-12 gnu: wget: Update to 1.19.1. ...* gnu/packages/wget.scm (wget): Update to 1.19.1.
Marius Bakke
2017-02-06 gnu: wget: Use libidn2. ...Suggested by Efraim Flashner <efraim@flashner.co.il>.
Fixes support for internationalized domain names.
* gnu/packages/wget.scm (wget)[inputs]: Replace libidn with libidn2.
Leo Famulari
2017-02-04 gnu: wget: Update to 1.19. ...* gnu/packages/wget.scm (wget): Update to 1.19.
[home-page]: Use HTTPS.
Marius Bakke
2016-11-29 gnu: Add wgetpaste. ...* gnu/packages/wget.scm (wgetpaste): New variable.
Efraim Flashner