From 6a08014b77bf435f025ecdac08396580b85f159a Mon Sep 17 00:00:00 2001 From: Jan Nieuwenhuizen Date: Sat, 8 Sep 2018 20:22:45 +0200 Subject: [PATCH] fix binary literals. --- module/nyacc/lex.scm | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/module/nyacc/lex.scm b/module/nyacc/lex.scm index 2ec9895..b205212 100644 --- a/module/nyacc/lex.scm +++ b/module/nyacc/lex.scm @@ -345,10 +345,11 @@ ((char-numeric? ch) (iter chl '$fixed ba 1 ch)) ((char=? #\. ch) (iter (cons ch chl) #f ba 15 (read-char))) (else #f))) - ((10) ;; allow x after 0 + ((10) ;; allow x, b after 0 (cond ((eof-object? ch) (iter chl ty ba 5 ch)) ((char=? #\x ch) (iter (cons ch chl) ty 16 1 (read-char))) + ((char=? #\b ch) (iter (cons ch chl) ty 2 1 (read-char))) (else (iter chl ty ba 1 ch)))) ((15) ;; got `.' only (cond -- 2.18.0 witch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/animation.scm
AgeCommit message (Expand)Author
2023-06-17gnu: lightspark: Update to 0.8.7....Vinicius Monego
2023-05-02gnu: rlottie: Fix building with GCC....unwox
2023-03-31gnu: Replace all uses of atk by at-spi2-core....Josselin Poiret
2023-01-15gnu: lightspark: Update to 0.8.6.1....Tobias Geerinckx-Rice
2023-01-04gnu: synfigstudio: Update to 1.4.4....Ricardo Wurmus
2023-01-04gnu: synfigstudio: Use gexp....Ricardo Wurmus
2023-01-04gnu: synfig: Update to 1.4.4....Ricardo Wurmus
2023-01-04gnu: etl: Update to 1.4.4....Ricardo Wurmus
2022-10-27gnu: swftools: Fix typos....Vagrant Cascadian
2022-10-23gnu: Fix typos....Vagrant Cascadian
2022-08-30gnu: Add swftools....Tomasz Jeneralczyk
2022-08-21gnu: lightspark: Remove input labels....Vinicius Monego
2022-08-21gnu: lightspark: Update to 0.8.6....Vinicius Monego
2022-08-21gnu: lightspark: Remove optional input gnash....Vinicius Monego
2022-07-31gnu: qttools: Rename to qttools-5....Maxim Cournoyer
2022-07-31gnu: qtmultimedia: Rename to qtmultimedia-5....Maxim Cournoyer
2022-07-31gnu: qtsvg: Rename variable to qtsvg-5....Maxim Cournoyer