From 6a08014b77bf435f025ecdac08396580b85f159a Mon Sep 17 00:00:00 2001 From: Jan Nieuwenhuizen Date: Sat, 8 Sep 2018 20:22:45 +0200 Subject: [PATCH] fix binary literals. --- module/nyacc/lex.scm | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/module/nyacc/lex.scm b/module/nyacc/lex.scm index 2ec9895..b205212 100644 --- a/module/nyacc/lex.scm +++ b/module/nyacc/lex.scm @@ -345,10 +345,11 @@ ((char-numeric? ch) (iter chl '$fixed ba 1 ch)) ((char=? #\. ch) (iter (cons ch chl) #f ba 15 (read-char))) (else #f))) - ((10) ;; allow x after 0 + ((10) ;; allow x, b after 0 (cond ((eof-object? ch) (iter chl ty ba 5 ch)) ((char=? #\x ch) (iter (cons ch chl) ty 16 1 (read-char))) + ((char=? #\b ch) (iter (cons ch chl) ty 2 1 (read-char))) (else (iter chl ty ba 1 ch)))) ((15) ;; got `.' only (cond -- 2.18.0 h'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/logging.scm
sg-avail'>...The regression was introduce with commit c7793b82efd3383a9f7adf0dfa82d71ee032e41b ("gnu: raspberry-pi: Add a bootloader-chain for the Raspberry Pi and os examples.") due to the examples needing to be built for the aarch64-linux system. * tests/guix-system.sh: Invoke guix system build with '--system=aarch64-linux' to build the Raspberry Pi systems.
AgeCommit message (Expand)Author
2022-01-21gnu: spdlog: Build shared library....* gnu/packages/logging.scm (spdlog)[arguments]: Enable SPDLOG_BUILD_SHARED flag. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> raingloom
2021-12-31gnu: rsyslog: Update to 8.2112.0....* gnu/packages/logging.scm (rsyslog): Update to 8.2112.0. Ricardo Wurmus
2021-12-31gnu: Add rsyslog....* gnu/packages/logging.scm (rsyslog): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> Co-authored-by: Ricardo Wurmus <rekado@elephly.net> Katherine Cox-Buday
2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès
2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-11-14gnu: spdlog: Update to 1.9.2....* gnu/packages/logging.scm (spdlog): Update to 1.9.2. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan
Maxim Cournoyer
2022-10-07tests: Attempt to build 'desktop.tmpl' on all major architectures....Partly fixes <https://issues.guix.gnu.org/58352>. * tests/guix-system.sh: Try to build 'desktop.tmpl' for x86_64, i686, and aarch64. Ludovic Courtès
2022-09-04guix system: Do not use 'vm-image.tmpl' in tests....This is a followup to 95a03aa5c507d48e2cde19ea007b8f90a4e0108a. Since that commit, merely evaluating 'vm-image.tmpl' would trigger the build of 'current-guix' so skip it. * tests/guix-system.sh: Do not try to build 'vm-image.tmpl'. Ludovic Courtès