This patch originates from the Debian project, see https://www.debian.org/ 18dbpagesize_binpower.dpatch by Make sure that the pagesize passed to db__set_pagesize() is a power of two. nvi stores the content of files in BDB database structures. When initiating a file, it picks a page size for the database to fit the file within 15 pages, with a minimal page size of 1K and maximal of 10K. In vanilla nvi, this size is calculated as a multiple of 1024. Modern versions of BDB, however, require the page size of a database to be a power of two, which this patch addresses, ridding us of the following message: BDB0511 page sizes must be a power-of-2 --- nvi-1.81.6.orig/common/exf.c 2009-03-09 01:48:01.695862889 +0100 +++ nvi-1.81.6/common/exf.c 2009-03-09 10:42:41.147866272 +0100 @@ -249,11 +249,10 @@ * (vi should have good locality) or smaller than 1K. */ psize = ((sb.st_size / 15) + 1023) / 1024; - if (psize > 10) - psize = 10; - if (psize == 0) - psize = 1; - psize *= 1024; + if (psize >= 8) psize=8<<10; + else if (psize >= 4) psize=4<<10; + else if (psize >= 2) psize=2<<10; + else psize=1<<10; F_SET(ep, F_DEVSET); ep->mdev = sb.st_dev; linux.scm'>logtreecommitdiff
path: root/gnu/bootloader/extlinux.scm
AgeCommit message (Expand)Author
2019-03-16bootloader: Use 'invoke/quiet' when running 'grub-install' and co....Ludovic Courtès
2019-03-13Remove traces of "GuixSD"....Ludovic Courtès
2018-11-18bootloader: De-monadify configuration file generators....Ludovic Courtès
2018-05-12bootloader: extlinux: Fix menu support with u-boot....Vagrant Cascadian
2017-12-15bootloader: Factorize write-file-on-device....Mathieu Othacehe
2017-12-04bootloader: extlinux: Stop using dd binary....Mathieu Othacehe
2017-11-23bootloader: extlinux: Fix device tree path....Mathieu Othacehe
2017-07-28bootloader: Use <menu-entry> for the bootloader side....Danny Milosavljevic
2017-06-21bootloader: extlinux: Add extlinux-bootloader-gpt....Mathieu Othacehe
2017-06-08bootloader: Use menu-entry to define custom bootloader entries....Mathieu Othacehe
2017-05-21bootloader: extlinux: Add a warning message on top of generated conf file....Mathieu Othacehe
2017-05-18bootloader: extlinux: Remove syslinux-bootloader....Mathieu Othacehe
2017-05-18bootloader: extlinux: Remove undefined symbols from export list....Mathieu Othacehe
2017-05-16bootloader: Add extlinux support....Mathieu Othacehe