This patch originates from the Debian project, see https://www.debian.org/ 18dbpagesize_binpower.dpatch by Make sure that the pagesize passed to db__set_pagesize() is a power of two. nvi stores the content of files in BDB database structures. When initiating a file, it picks a page size for the database to fit the file within 15 pages, with a minimal page size of 1K and maximal of 10K. In vanilla nvi, this size is calculated as a multiple of 1024. Modern versions of BDB, however, require the page size of a database to be a power of two, which this patch addresses, ridding us of the following message: BDB0511 page sizes must be a power-of-2 --- nvi-1.81.6.orig/common/exf.c 2009-03-09 01:48:01.695862889 +0100 +++ nvi-1.81.6/common/exf.c 2009-03-09 10:42:41.147866272 +0100 @@ -249,11 +249,10 @@ * (vi should have good locality) or smaller than 1K. */ psize = ((sb.st_size / 15) + 1023) / 1024; - if (psize > 10) - psize = 10; - if (psize == 0) - psize = 1; - psize *= 1024; + if (psize >= 8) psize=8<<10; + else if (psize >= 4) psize=4<<10; + else if (psize >= 2) psize=2<<10; + else psize=1<<10; F_SET(ep, F_DEVSET); ep->mdev = sb.st_dev; 92fbf0ab25b87205850c9f0cd13e6b656'>treecommitdiff
path: root/d3.v3.js
t'>Author
AgeCommit message (Expand)Author
2020-07-17gitignore: Don't ignore daemon source code....Jakub Kądziołka
2020-06-28.gitignore: Ignore 'etc/committer.scm'....Brice Waegeneire
2020-05-16etc: Add a systemd unit to bind-mount @storedir@ read-only....Tobias Geerinckx-Rice
2020-05-14etc: indent-code.el: Use the --quick option....Maxim Cournoyer
2020-03-30.gitignore: Ignore test results in tests/services....Marius Bakke
2020-03-11Add system start-up files for guix-daemon....Danny Milosavljevic
2019-09-24Merge branch 'master' into core-updatesLudovic Courtès
2019-09-18doc: Add Guix Cookbook....Ricardo Wurmus
2019-06-14build: Remove 'gnu/packages/bootstrap' and its binaries....Ludovic Courtès
2019-04-26bootstrap: Break automake dependency on generated files....Miguel Ángel Arruga Vivas
2018-11-20.gitignore: Re-add 'authenticate' script....Marius Bakke
2018-06-14Remove 'guix-register' and its traces....Ludovic Courtès
2018-06-12.gitignore: Add doc/stamp-[0-9].Ludovic Courtès
2018-04-19gnu: doc: Allow documentation to be translated....Julien Lepiller
2018-02-13.gitignore: Add guix-daemon SELinux policy....Efraim Flashner
2017-05-13.gitignore: Ignore Emacs auto-save files....ng0
2017-05-08build: Add doc/guix.html to .gitignore....Clément Lassieur