This patch originates from the Debian project, see https://www.debian.org/ 18dbpagesize_binpower.dpatch by Make sure that the pagesize passed to db__set_pagesize() is a power of two. nvi stores the content of files in BDB database structures. When initiating a file, it picks a page size for the database to fit the file within 15 pages, with a minimal page size of 1K and maximal of 10K. In vanilla nvi, this size is calculated as a multiple of 1024. Modern versions of BDB, however, require the page size of a database to be a power of two, which this patch addresses, ridding us of the following message: BDB0511 page sizes must be a power-of-2 --- nvi-1.81.6.orig/common/exf.c 2009-03-09 01:48:01.695862889 +0100 +++ nvi-1.81.6/common/exf.c 2009-03-09 10:42:41.147866272 +0100 @@ -249,11 +249,10 @@ * (vi should have good locality) or smaller than 1K. */ psize = ((sb.st_size / 15) + 1023) / 1024; - if (psize > 10) - psize = 10; - if (psize == 0) - psize = 1; - psize *= 1024; + if (psize >= 8) psize=8<<10; + else if (psize >= 4) psize=4<<10; + else if (psize >= 2) psize=2<<10; + else psize=1<<10; F_SET(ep, F_DEVSET); ep->mdev = sb.st_dev; href='/guix/tree/gnu/packages/coq.scm?id=9bf27e5f4235241b84cfcc112c43a8d39a5fd25e'>treecommitdiff
path: root/gnu/packages/coq.scm
AgeCommit message (Expand)Author
2024-06-26gnu: proof-general: Update to 4.5@cb23709a....Arnaud Daby-Seesaram
2024-06-23gnu: coq-autosubst: Fix Coq 8.19 compatibility....Jean-Pierre De Jesus DIAZ
2024-06-16gnu: coq-stdpp: Update to 1.10.0....Jean-Pierre De Jesus DIAZ
2024-06-16gnu: coq-mathcomp: Update to 1.19.0....Jean-Pierre De Jesus DIAZ
2024-06-16gnu: coq-interval: Update to 4.10.0....Jean-Pierre De Jesus DIAZ
2024-06-16gnu: coq-gappa: Update to 1.5.5....Jean-Pierre De Jesus DIAZ
2024-06-16gnu: coq-coquelicot: Update to 3.4.1....Jean-Pierre De Jesus DIAZ
2024-05-15gnu: coq-flocq: Update to 4.1.4....Jean-Pierre De Jesus DIAZ
2024-02-08gnu: coq: Update to 8.17.1....pukkamustard
2024-02-08gnu: Update coq-interval to 4.8.0....pukkamustard
2024-02-08gnu: Update coq-stdpp to 1.8.0....pukkamustard
2024-02-08gnu: Update coq-autosubst to 1.8....pukkamustard
2024-02-08gnu: Update coq-mathcomp to 1.17.0....pukkamustard
2024-02-08gnu: Update coq-coquelicot to 3.4.0....pukkamustard
2024-02-08gnu: Update coq-gappa to 1.5.3....pukkamustard
2024-02-08gnu: Update coq-flocq to 4.1.1....pukkamustard
2023-11-23gnu: Add coq-for-coqtail....Jean-Pierre De Jesus DIAZ