This patch originates from the Debian project, see https://www.debian.org/ 18dbpagesize_binpower.dpatch by Make sure that the pagesize passed to db__set_pagesize() is a power of two. nvi stores the content of files in BDB database structures. When initiating a file, it picks a page size for the database to fit the file within 15 pages, with a minimal page size of 1K and maximal of 10K. In vanilla nvi, this size is calculated as a multiple of 1024. Modern versions of BDB, however, require the page size of a database to be a power of two, which this patch addresses, ridding us of the following message: BDB0511 page sizes must be a power-of-2 --- nvi-1.81.6.orig/common/exf.c 2009-03-09 01:48:01.695862889 +0100 +++ nvi-1.81.6/common/exf.c 2009-03-09 10:42:41.147866272 +0100 @@ -249,11 +249,10 @@ * (vi should have good locality) or smaller than 1K. */ psize = ((sb.st_size / 15) + 1023) / 1024; - if (psize > 10) - psize = 10; - if (psize == 0) - psize = 1; - psize *= 1024; + if (psize >= 8) psize=8<<10; + else if (psize >= 4) psize=4<<10; + else if (psize >= 2) psize=2<<10; + else psize=1<<10; F_SET(ep, F_DEVSET); ep->mdev = sb.st_dev; href='/guix/tree/gnu/packages/lua.scm?id=9fd6ad3e3557a8efeadf182af60e32c77b62b2af'>treecommitdiff
path: root/gnu/packages/lua.scm
AgeCommit message (Expand)Author
2019-01-08gnu: Add lua5.2-sec....Clément Lassieur
2019-01-08gnu: Add lua-filesystem and lua5.2-filesystem....Clément Lassieur
2019-01-08gnu: Add lua5.2-socket....Clément Lassieur
2019-01-08gnu: Add lua5.2-expat....Clément Lassieur
2019-01-07gnu: Remove unnecessary build-side module imports....Ludovic Courtès
2018-10-26gnu: Add lua5.1-lpeg and lua5.1-lmpack....HiPhish
2018-07-10gnu: lua: Update to 5.3.5....Marius Bakke
2018-03-23gnu: lua5.1-socket: Use invoke....Mark H Weaver
2018-03-23gnu: lua5.1-expat: Use invoke....Mark H Weaver
2018-03-23gnu: lua: Use invoke....Mark H Weaver
2018-03-17gnu: Fix common unquote typos....Tobias Geerinckx-Rice
2018-02-09Merge branch 'master' into core-updatesMark H Weaver
2018-02-08gnu: luajit, lua5.x-bitop: Use HTTPS home pages....Tobias Geerinckx-Rice
2018-02-08gnu: luajit: Make available as ‘luajit’....Tobias Geerinckx-Rice
2018-02-08gnu: luajit: Update to 2.1.0-beta3....Tobias Geerinckx-Rice