This patch originates from the Debian project, see https://www.debian.org/ 18dbpagesize_binpower.dpatch by Make sure that the pagesize passed to db__set_pagesize() is a power of two. nvi stores the content of files in BDB database structures. When initiating a file, it picks a page size for the database to fit the file within 15 pages, with a minimal page size of 1K and maximal of 10K. In vanilla nvi, this size is calculated as a multiple of 1024. Modern versions of BDB, however, require the page size of a database to be a power of two, which this patch addresses, ridding us of the following message: BDB0511 page sizes must be a power-of-2 --- nvi-1.81.6.orig/common/exf.c 2009-03-09 01:48:01.695862889 +0100 +++ nvi-1.81.6/common/exf.c 2009-03-09 10:42:41.147866272 +0100 @@ -249,11 +249,10 @@ * (vi should have good locality) or smaller than 1K. */ psize = ((sb.st_size / 15) + 1023) / 1024; - if (psize > 10) - psize = 10; - if (psize == 0) - psize = 1; - psize *= 1024; + if (psize >= 8) psize=8<<10; + else if (psize >= 4) psize=4<<10; + else if (psize >= 2) psize=2<<10; + else psize=1<<10; F_SET(ep, F_DEVSET); ep->mdev = sb.st_dev; ix/tree/gnu/tests/ssh.scm?id=8d7c4b610f0b880a88eb798b36d05933c2e01591'>treecommitdiff
path: root/gnu/tests/ssh.scm
AgeCommit message (Expand)Author
2018-10-18services: dhcp-client: Deprecate 'dhcp-client-service' procedure....Ludovic Courtès
2018-06-13tests: Honor the return value of 'start-service'....Clément Lassieur
2018-06-01tests: ssh: Use 'with-extensions'....Ludovic Courtès
2017-11-01tests: ssh: Make sure we can run executables from PATH....Marius Bakke
2017-07-23Merge branch 'master' into core-updatesLeo Famulari
2017-07-20tests: Use 'virtual-machine' records instead of monadic procedures....Ludovic Courtès
2017-07-18tests: ssh: Use 'guile-ssh'....Ludovic Courtès
2017-06-12marionette: Factorize 'wait-for-file'....Ludovic Courtès
2017-05-21tests: ssh: Use 'guile2.0-ssh'....Ludovic Courtès
2017-04-01tests: Introduce 'simple-operating-system' and use it....Ludovic Courtès
2017-03-21tests: ssh: Add a test for SFTP....Clément Lassieur
2017-03-21tests: ssh: Abstract session connection and authentication....Clément Lassieur
2016-10-03tests: ssh: Add Dropbear test....Ludovic Courtès
2016-10-03tests: ssh: Generalize....Ludovic Courtès
2016-10-03tests: Add 'openssh-service-type' test....Ludovic Courtès