This patch originates from the Debian project, see https://www.debian.org/ 03db4.dpatch by libdb4 compatibility adjustments. In particular, this patch adds extra file permission checking and passes the DB_CREATE flag to the first invocation of db_open on the file's database structure, which rids us of the following message: BDB0635 DB_CREATE must be specified to create databases. --- nvi-1.81.6.orig/common/msg.c 2009-02-26 14:26:58.350336128 +0100 +++ nvi-1.81.6/common/msg.c 2009-02-26 14:29:05.235335829 +0100 @@ -724,9 +724,18 @@ p = buf; } else p = file; + if (access(p, F_OK) != 0) { + if (first) { + first = 0; + return (1); + } + sp->db_error = ENOENT; + msgq_str(sp, M_DBERR, p, "%s"); + return (1); + } if ((sp->db_error = db_create(&db, 0, 0)) != 0 || (sp->db_error = db->set_re_source(db, p)) != 0 || - (sp->db_error = db_open(db, NULL, DB_RECNO, 0, 0)) != 0) { + (sp->db_error = db_open(db, NULL, DB_RECNO, DB_CREATE, 0)) != 0) { if (first) { first = 0; return (1); bout/'>aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
AgeCommit message (Expand)Author
2019-04-04gnu: Add kdeconnect....Efraim Flashner
2019-02-14gnu: Restore copyright header....Marius Bakke
2019-02-12gnu: Move KDE Plasma components to separate module....Marius Bakke
2019-01-28gnu: Krita: Update to 4.1.7.101....Björn Höfling
2019-01-26gnu: libksysguard: Use INVOKE....Ricardo Wurmus
2018-12-13gnu: Fix misplaced commas (unquotes)....Mark H Weaver
2018-10-24gnu: Add libkscreen....Meiyo Peng
2018-10-11gnu: Krita: Update to 4.1.5....Leo Famulari
2018-10-10gnu: Add kdenlive....Mark Meyer
2018-09-28gnu: Krita: Update to 4.1.3....Leo Famulari
2018-09-01gnu: Remove Krita 3....Leo Famulari
2018-09-01gnu: Krita: Build with libraw 0.18....Leo Famulari
2018-09-01gnu: Krita: Update to 4.1.1....Leo Famulari
2018-09-01gnu: libksysguard: Update to 5.13.4....Leo Famulari