This patch originates from the Debian project, see https://www.debian.org/ 03db4.dpatch by libdb4 compatibility adjustments. In particular, this patch adds extra file permission checking and passes the DB_CREATE flag to the first invocation of db_open on the file's database structure, which rids us of the following message: BDB0635 DB_CREATE must be specified to create databases. --- nvi-1.81.6.orig/common/msg.c 2009-02-26 14:26:58.350336128 +0100 +++ nvi-1.81.6/common/msg.c 2009-02-26 14:29:05.235335829 +0100 @@ -724,9 +724,18 @@ p = buf; } else p = file; + if (access(p, F_OK) != 0) { + if (first) { + first = 0; + return (1); + } + sp->db_error = ENOENT; + msgq_str(sp, M_DBERR, p, "%s"); + return (1); + } if ((sp->db_error = db_create(&db, 0, 0)) != 0 || (sp->db_error = db->set_re_source(db, p)) != 0 || - (sp->db_error = db_open(db, NULL, DB_RECNO, 0, 0)) != 0) { + (sp->db_error = db_open(db, NULL, DB_RECNO, DB_CREATE, 0)) != 0) { if (first) { first = 0; return (1); ref='/guix/about/'>aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/telephony.scm
AgeCommit message (Expand)Author
2022-09-23services: jami-service-type: Streamline stop slot....Maxim Cournoyer
2022-08-25services: Use the new maybe/unset API....Attila Lendvai
2022-08-01services: configuration: Step back from *unspecified*....Maxim Cournoyer
2022-06-15services: configuration: Use *unspecified* instead of 'disabled....Attila Lendvai
2022-06-10services: jami-configuration: Rename 'jamid' field to 'libjami'....Maxim Cournoyer
2022-06-10services: jami: Modernize to adjust to Shepherd 0.9+ changes....Maxim Cournoyer
2022-04-12services: Replace murmur-service-type with mumble-server-service-type....Liliana Marie Prikler
2022-03-24services: murmur: Fix server program name....fesoj000
2022-01-13services: Adjust the jami service for the upgraded jami....Maxim Cournoyer
2021-11-30services: Accept <inferior-package>s in lieu of <package>s....Tobias Geerinckx-Rice
2021-08-02Reinstate "services: Add a service for Jami."...Maxim Cournoyer
2021-08-02Revert "services: Add a service for Jami."...Maxim Cournoyer
2021-08-02services: Add a service for Jami....Maxim Cournoyer