This patch originates from the Debian project, see https://www.debian.org/ 03db4.dpatch by libdb4 compatibility adjustments. In particular, this patch adds extra file permission checking and passes the DB_CREATE flag to the first invocation of db_open on the file's database structure, which rids us of the following message: BDB0635 DB_CREATE must be specified to create databases. --- nvi-1.81.6.orig/common/msg.c 2009-02-26 14:26:58.350336128 +0100 +++ nvi-1.81.6/common/msg.c 2009-02-26 14:29:05.235335829 +0100 @@ -724,9 +724,18 @@ p = buf; } else p = file; + if (access(p, F_OK) != 0) { + if (first) { + first = 0; + return (1); + } + sp->db_error = ENOENT; + msgq_str(sp, M_DBERR, p, "%s"); + return (1); + } if ((sp->db_error = db_create(&db, 0, 0)) != 0 || (sp->db_error = db->set_re_source(db, p)) != 0 || - (sp->db_error = db_open(db, NULL, DB_RECNO, 0, 0)) != 0) { + (sp->db_error = db_open(db, NULL, DB_RECNO, DB_CREATE, 0)) != 0) { if (first) { first = 0; return (1); /about/'>aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/pcre.scm
AgeCommit message (Expand)Author
2017-07-23Merge branch 'master' into core-updatesLeo Famulari
2017-07-20gnu: pcre: Update replacement to 8.41 [fixes CVE-2017-{7244,7245,7246}]....Leo Famulari
2017-07-03packages: Mark 'replacement' as an "innate" field....Ludovic Courtès
2017-05-24Merge branch 'master' into core-updatesRicardo Wurmus
2017-05-07gnu: pcre2: Fix build configuration for pcre2....Leo Famulari
2017-05-07gnu: pcre2: Fix CVE-2017-8786....Leo Famulari
2017-04-10gnu: pcre: Patch CVE-2017-7186....Ludovic Courtès
2017-04-10gnu: pcre2: Patch CVE-2017-7186....Ludovic Courtès
2017-03-09Merge branch 'master' into core-updatesLudovic Courtès
2017-03-07gnu: pcre2: Update to 10.23....Marius Bakke
2017-01-23gnu: pcre: Update to 8.40....Leo Famulari
2016-06-07Merge branch 'master' into core-updatesLudovic Courtès
2016-05-29gnu: pcre2: Fix CVE-2016-3191....Leo Famulari
2016-05-23gnu: pcre: Remove now-unneeded replacement....Ludovic Courtès
2016-05-02gnu: pcre: Add "bin" output....Ludovic Courtès
2016-05-02Merge branch 'master' into core-updatesMathieu Lirzin